PLEASE help, Profile Pictures

I just installed elgg and i'm LOVING it, just having 2 problems with members uploading profile pictures.

1. If a member puts a photo larger than about 600K it will give me a fatal error message saying there is a error in line 898 of filestore,

2. (BIG problem) even if members get around this and upload a pic, ALL of their friends who have uploaded a photo will share the SAME picture,


Please help as I plan to launch this site for over 200 users, thanks!



  • On 1, it would be nice to know the error message. I'm guesing that your server does not allocate enough memory for PHP.

    Number 2 should not be happening. I've never seen that on any install that I have done. Could you provide some information on your server? What OS? What version of PHP? Is PHP running as an Apache module or as a cgi process?

  • Thanks for responding, for problem number 1 the error message is as follows:

    Fatal error: Allowed memory size of 18874368 bytes exhausted (tried to allocate 10368 bytes) in /hermes/web07/b2414/moo.chrawad/one/engine/lib/filestore.php on line 898

    please help!

    as far as the problem 2 (the BIG problem):

    OS: Debian, PHP version 5.2.2, PHP running as an Apace Module

    Any help would be great thanks!


  • Try-->

    ; Resource Limits ;
    max_execution_time       =  600
    max_input_time           =  600
    memory_limit             = 1024M
    post_max_size            =    8M

    ; File Uploads ;
    ; Whether to allow HTTP file uploads.
    file_uploads            = On
    ; Temporary directory for HTTP uploaded files (will use system default if not
    ; specified).
    ; upload_tmp_dir =
    ; Maximum allowed size for uploaded files.
    upload_max_filesize    = 2M

  • sorry if this is silly, but where exactly do i edit/find to write that?

  • because i dont see a place in the .httacess file for me to enter that, in my .httaccess file is states:


    <IfModule mod_php5.c>

    # default memory limit to 64Mb

    php_value memory_limit 64Mb

    # to make sure register global is off

    php_value register_globals 0

    # max post size to 8Mb

    php_value post_max_size 8388608

    # upload size limit to 5Mb

    php_value upload_max_filesize 5242880

    # hide errors, enable only if debug enabled

    php_value display_errors 0


  • Chris - right now PHP is limited to 18 MB. The default for this is set in your php.ini. Elgg's .htaccess tries to set it to 64 MB ("php_value memory_limit 64Mb"). It doesn't look like this is being picked up. You may need to speak to the administer of the server to see why you are limited to 18 MB.