Installation failed with ELGG 1.7 and WAMP - ModRewrite dont work ?

hi all,

i just hope i can get some help with all the experienced dudes !

My configuration :

ELGG 1.7 / wamp server on my local computer

WAMP server 2.0  :

php 5.3.0
Apache 2.2.11
mysql 5.1.36

what i did on wamp:

php modules > gd2 ON
apache modules > rewrite module ON


on ELGG files

  • i uncommented the 117 line in .htaccess

RewriteBase /

  • i put the total rights on the "data" directory by windows properties panel

but when i click on my "http://localhost/groupware/elgg/testing.php" i have a error 404 page, and i absolutely confirm that the 2 both pages are in the same directory. So... how can i fix it???

i tried to change in the .htaccess the line 110 with the sub-directory. with or without it s the same result.

(#)RewriteBase /groupware/elgg/

after all of that

i still have the same error when i reload elgg homepage :

"Elgg couldn't connect to the database using the given credentials."


anyone can help ??

thanx so much !