Lost all profile / group images after upgrading


After upgrading Elgg to 1.7 every members profile image and every group image has been reset to the ugly default image. Does anyone know how to fix this?

  • @Dan - if you are still getting the database exception you posted above, your primary problem is that you database has not been upgraded. Look in your datalists table and find the entry for "version". Post that here.

  • I have tried data permissions at 777 and 755 and still no good.

    We have manually fixed the SQL errors by installing 1.7 on another server, finding the differences and making the updates required manually, but still cannot fix the issue with profile images.

  • @Dan - if your version number is not set correctly in the datalists table, you will have difficulty with future upgrades. Actually, the entire approach you are taking to this sounds like trouble in the future.

    The upgrade consists of some php scripts and database schema updates. The schema updates are in /engine/schema/upgrades. The php scripts in /engine/lib/upgrades/

    It really sounds like the upgrade script never ran on your install. I believe the 1.6.1 internal version number was 2009072201. To do a manual upgrade, you would have to run each of the upgrade scripts with a larger version number.

    I would start with a 1.6.1 database and run the main upgrade script.

  • Version is 2009072201

    So looks like you are right... I'll see about the running the upgrade scripts.

    We have got some (most) of the site working now, but still having problems with some plugins (which should work with 1.7)

    Here is what has been done. http://kuevo.com/updatefix.php.txt

  • Alex (The coder) says..

    True about running the SQL updates from /engine/schema/upgrades but false regadring  /engine/lib/upgrades/
    In  /engine/lib/upgrades/ one can only find statemements to enable/disable a couple of plugins. The main difference between 1.6 and 1.7 is the directory structure of the data stored outside the public directory which changed from
    I'm sure they put some procedure to convert that structure somewhere but certainly not into /upgrades/


  • This works well to change the data directory structure to 1.7 http://kuevo.com/updatefix.php.txt

    If you are having this problem (seems some are), take this code, call it something.php upload to your server and run it.

  • @Dan - have Alex look at /engine/lib/upgrades/2009102801.php - that is where the directory structure is changed.


  • Thanks for all your help... The site is functional again now and next time I'll be smart and take a back up before I upgrade.

  • @cash just want to let you know that I have bookmarketed, tweeted and posted on my blog about what a fantastic helpful person you are.

    Thanks for your help



  • Dan Blackburn

    After running the script http://kuevo.com/updatefix.php.txt

    for most of the users i am getting this error (most of my user names are six digit numbers)

    Source path not exists. User created after the crash ?

    and i don't see any images after the script runs.. .... help me out plz