problem with user icons after 1.7 upgrade

After upgrading from 1.5 to 1.7 , and solving all ( non-upgraded ) plugis problems , i am still stuck with 1 problem, after you loged in , all members with icons turned to just 1 icon , which is your icon and profile picture with the account you logged in with, if you sign out , icons return back for each user with his own icon, logging with any account give you the same icon of this account for all users with icons, visitin any profile when you logged in als show your profile pictue as well, can anyone help me with this problem ??

  • That is not a core Elgg bug so far as I know. Sounds like you have a plugin problem somewhere. Try turning off everything but the core plugins.

  • thanx Kevin for your respond ,

    i did what you told me , and problem is still exist !!, i am really confused :(( , i am architect not a programer but allow me to guess that this problem is related to the way files was stored in 1.5 , and the new way in 1.7, this guess is not base on anything but feelings , i have no idea what i am talking about.


    could it be related to something wrong i did during upgrading ?? , thier is no manual for upgrading from 1.5 to 1.7 , so i try my luck with it on a production site :(( , how stupid am i ?? :)))

  • There is a step-by-step guide to upgrading to Elgg 1.7 here:

    You are reporting a very strange problem that I've not seen anywhere else, so I think that it may be specific to your server. I suggest that you restore your 1.5 site from a backup and try again using the guide.

  • i just ugraded to 1.7 same thing has happened, all user images are gone and my home page is all screwed up showing this message



    Unknown column 'annotation_id' in 'field list'

    QUERY: select id,type,subtype,action_type,access_id,view,subject_guid,object_guid,annotation_id,posted from el_river where ( (1 = 1) ) order by posted desc limit 0,21

  • @SU - your database was not upgraded. That column was added in Elgg 1.7. Make sure you run the upgrade script.

  • We tried to upgrade our dev server step by step following Wiki and instructions. Problems!

    1 - Import production data into dev (1.6.1). But after this loose all css, even though clearing out the cache. Luckely we find the menu options to disable Simplecache. (Enabling simplecache break css again), but we leave that for now. Files and icons are there. So that is good.

    2- Now we overwrite 1.6.1 with the 1.7 code. We hit localhost/upgrade.php...  get working icon... it shows a success message that database upgraded.... and....

    We also loose all files, icons ! :((

    Hmm... the upgrade script DID run... try difference...maybe .htaccess?  So, let's dump the old .htaccess and replace with .htaccess_dist ...nope... deleting .htaccess and let the Elgg cur and paste screen do it for me? Well, the screen pops up but there is no text to cut and paste 

    Gosh.... what can this be?

    OH: and be carefull not to switch on simplecache in 1.7 ... again all css is lost...

  • Tom, it sounds as though there is something wrong with your data directory post upgrade. Two options I can think of:

    a. no data upgrade happened for some reason, in which case the usernames would still be embedded in the file paths. Eg. t/o/m, Could you check that?

    b. the upgrade did occur, but the new data directory has the wrong permissions. All files and directories should be world readable/writable or at least readable/writable by your web server.

  • Hi Kevin,  indeed folders like t/o/m still exist in same way as before ... so you nailed it:

    1. dropped all tables,
    2. import sql backup again
    3. execute from shell chmod -R a+rwx /var/sndata  
    4. hit localhost/upgrade 
    And this time data is there:))  
    1. I see folders 2009 and 2010 so I delete the other folders in /var/sndata (except the cache) 
    Now the Q: Why do we need new permissions? Site and former upgrades ran fine... Can we prevent other elgg admins running in same issue?
  • Glad to hear that it worked.

    You don't need new permissions. I was just speculating that somehow the permissions got changed on your server. As you mentioned, the problem turned out to be possibility a.

    Strange that the data upgrade failed to run the first time.