Fatal error while upgrading previous release of plugin

Hi,
I am trying to upload new release of my plugin from the previous. I got a fatal error:
Fatal error: Call to a member function canEdit() on a non-object in /var/www/community.elgg.org/mod/plugins/actions/update.php on line 39
"

I just want to notify