Extreme load times for css.css

I've been having this issue since installing elgg a long time ago and I'm unable to find a solution. Running elgg on XAMPP platform and every page has an extreme load time for css.css. Usually more then 30 seconds sometimes a lot more. Does anyone have any idea on what's going on here? if you'd like to see what i'm referring to visit lakewylieboating.com.

PLEASE HELP!

  • Can anyone tell me how to truly disable the simple cache? unchecking the option within site administration does nothing.

  • I'd be really surprised if there was a problem with elgg running on XAMPP and Windows Server 2003. More likely to be a server configuration issue.

    Here are some things to try (one at a time and undo if it doesn't change anything):

    1. comment out the header("Content-Length...) calls in simplecache.php

    2. turning off the apache deflate module

    3. replacing the dynamic css file with a plain css file

     

    Unchecking the simple option does turn off caching. The URL will look the same but it creates the css on the fly rather than loading it from a cached version stored in the data directory.

  • Ok I'm getting somewhere, figured out why setting was not disabling cache. I've got the site to work fairly well running with the simple cache on and using Crome. That's the only browser I can use thought. Get the 30second load time every refresh to css.css file. Gonna try your suggestion Cash..

  • Comment out the header in simplecache.php are you referring to view.php within the simplecache directory?

     

  • THAT DID IT!!! one comment on line 50 of view.php and the site runs AWESOME!!! Now how do we fix it?

  • CASH - YOU ARE THE MAN!!! dude you have no idea how long i've been looking for this. Now if the comment did the trick, It's the simple cache.

  • Lloyd,

    I think that commenting out that line helps to narrow down the problem a bit, but it still sounds like you have a server configuration issue. Simplecache is designed to speed up your site, not slow it down, and in every other Elgg install I know about, that is what it does.

  • Kevin I have at least 12 domains running extensive php applications just fine on this same server. I have simple cache is the least of my concerns at this time. eAccellerator runs fine and the site I have configured runs very nicely. I can delete the views_simplecache folder and it's still created during a page refresh.

    I realize there is some concern with a substantial load and elgg sites. I'd love to get to that point and offload it to it's own machine but I don't see this happening for a while. This was mearly a test to see if I could get it running on this platform. The thing is simple cache is still running.

  • Kevin have you installed elgg on a XAMPP platform?

  • Lloyd, could you look up the value for mbstring.func_overload in your php configuration?