Extreme load times for css.css

I've been having this issue since installing elgg a long time ago and I'm unable to find a solution. Running elgg on XAMPP platform and every page has an extreme load time for css.css. Usually more then 30 seconds sometimes a lot more. Does anyone have any idea on what's going on here? if you'd like to see what i'm referring to visit lakewylieboating.com.


  • @Lloyd,

    Same old problem !

    The problem is *not, *not css.css --> the cause has to be the same as several months before... do you remember how many elggxperts spent how much time giving you super advice while you seemed to be not listening to anyone ? I just spent abt 7 minutes checking your site. your *server is doing *something *funky -- after sending *all *the *data but then does *not *let *go - instead keeps the browser hanging as if expecting there's more data coming... all the physical browser requests get satisfied within ***one second***

  • Yes same ol problem, no joy yet. I agree something "funky" is going on with the server but what escapes me is I have no idea where it's coming from. I've done everything the community has suggested to try and fix this. I have plenty of domains running of other php/mysql apps without issue on this server. Has anyone successfully configured an internet facing or external domain on XAMPP?

  • @Lloyd,

    I remember that older post. And no - I do not remember your looking into "..hire a server performance consultant to look into the "chunking" situation." nor "..looking into the "ACK" signal not coming back as speedily as expected." ;-( I just (yet once again) compared load times with yr Lake and another v1.5 Elgg site.. 30 sec vs 1 sec...! Get a server consultant, buddy or.. dig into the httpd.conf params ;-) The answer is in there somewhere...

  • Does anyone have an http.conf that I could compare with?

  • My issue seems to stem from this line within .htaccess

    RewriteRule ^\_css\/css\.css$ _css/css.php


    but any changes of course disables the style sheet.

    any ideas?

  • Brett
    168 days ago

    ... I've tested 3 times using wireshark to take a look at the TCP activity.  30 seconds each time.  This indicates a timeout somewhere.  The full CSS loads, and then then an ACK is sent from the server.  30 seconds pass, then the FIN, ACK is sent back.

    This could indicate either a problem with your compression, as Dhrup mentioned, or even a problem with network configuration settings if you have special rules running in ip filters or so...


  • Is anyone else here having issues running elgg? I don't know what I did to piss off Dhrup but I'd sure like to know. No I haven't been able to figure out what's going on and I'm sorry but hiring a server performance consultant is not what I'd consider a solution to this matter. I don't understand why you have to be so rude to people. That really doesn't get us anywhere. I understand your tech skills are quite awesome and I the effort you've put into this community is well, quite awesome too but your professionalism and understanding with people that don't possess those same skills....? How about a little patients for those of us that don't see things are you do.  I think that could go a long way in helping others. Whatever I did I apologize for.

    Ok from what i've tried and what I can come up with this seems to be an issue with rewriting. I don't have any IP rules and "I THINK!!!" compression is configured but not enabled for this domain. Is it possible that some options within .htaccess are being ignored? I found a couple post where people running Windows were having this problem.

    I'm using Zend with eAccellerator on the server. But the other domains run just find and everything seems to work. Making changes to these setting will effect everything so I'm a little hesitant to do so at this time.

    I agree the 30 second timeout is suspecious with everypage load. I don't see anything associated with that time amount within my configuration files, or maybe I'm missing something here.

    I've tried installing elgg on another server and had the same issue. This server was configured "almost exactly the same" with a single domain.

    Does anyone have a configuration I could examine for Windows/XAMPP? host.conf, vhost, php.ini?


  • LLoyd.. LOLZ ;-) I didn't mean to sound rude.... I'm not p/off.. I do believe the answer is there in Brett's earlier comment. Last time (160+ days ago) -- you might remember, many of us freely gave a lot of patient and studied technical comments. Believe it when I say --> you do need to find some server consultant who can dig into your httpd conf and other server internals. I do not believe the solution will come from a few simple lines of comments to "do this and do that..." ;-) Regards.

  • @Lloyd

    Hey there, I setup a windows xampp and have no 30 second loading issues.

    I made the following changes to xampp:

    • disabled server side includes
    • enable ipv4 only
    • disable apache:ASP
    • modified vhosts config

    Hope that helps.


    1. uncomment #NameVirtualHost *:80  (remove the #)
    2. Added the following:

    ## Vhost 1 config

    <VirtualHost *:80>
    DocumentRoot C:/xampp/htdocs/vhost1/html
    ServerName vhost1domainname
    ErrorLog "logs/vhost1-error.log"
    CustomLog "logs/vhost1-access.log" common

    ##Localhost to allow access to all xampp web tools

    <VirtualHost *:80>
    DocumentRoot C:/xampp/htdocs
    ServerName localhost

  • I have tried everything!! I've even had a network administrator look at the issue and my dns settings are fine. We've been able to narrow it down to the simple cache and I'm unsuccessfull at trying to disable it.

    elgg_noob you obviously are running elgg locally and without other vhosts configured. This is a dedicated server and I've come to the conclusion that elgg just does not run well on Windows Server 2003 with XAMPP.

    Has anyone had any luck configuring XAMPP / Windows Server 2003 and elgg together. Server is running dns, mysql and php 5.2.

    I'm banging my head against a wall here.