Plugins are having isses

I am new to all of this and I am trying to get this work.  I am on elgg 1.6.  For some reason everytime I enable a plugin I get the same error message:

Welcome to Elgg.

<!-- display any system messages -->


Plugin custom_topbar_link was enabled successfully.


custom_topbar_link is a misconfigured plugin.

Is there soething I am doing wrong?  I have unistalled and reinstalle a few times and still the same thing.  I can't get my pollsto work either.  I was reading about a plugin mught be missing a start page, but I don't know what a start page is.  Is it specific to a wbesite?  Can someone help the metally challenged?  Thanks to anyone who can help.  Fell free to email me at

  • Here's another one

    PluginException Object
    [message:protected] => elgg_mobile_RC1 is a misconfigured plugin.
    [string:private] => exception 'PluginException' with message 'elgg_mobile_RC1 is a misconfigured plugin.' in /home/content/z/0/9/z09jmm/html/nation/engine/lib/plugins.php:245
    Stack trace:
    #0 /home/content/z/0/9/z09jmm/html/nation/engine/start.php(175): load_plugins()
    #1 /home/content/z/0/9/z09jmm/html/nation/engine/handlers/pagehandler.php(16): require_once('/home/content/z...')
    #2 {main}
    [code:protected] => 0
    [file:protected] => /home/content/z/0/9/z09jmm/html/nation/engine/lib/plugins.php
    [line:protected] => 245
    [trace:private] => Array
    [0] => Array
    [file] => /home/content/z/0/9/z09jmm/html/nation/engine/start.php
    [line] => 175
    [function] => load_plugins
    [args] => Array


    [1] => Array
    [file] => /home/content/z/0/9/z09jmm/html/nation/engine/handlers/pagehandler.php
    [line] => 16
    [args] => Array
    [0] => /home/content/z/0/9/z09jmm/html/nation/engine/start.php

    [function] => require_once



  • I can't believe I can't get any input. I'm not asking anyone to do any work for me, I just need someone to point me in the right direction. I am really suprised at the lack of support.

  • I did check there. It was the first place I looked. It is not any of those issues. Thank you very much for responding. Do you have any other info that I could read that may help me? It would be greatly appricieated.>

  • Here's code from engline/lib/plugins.php:

      if (!include($CONFIG->pluginspath . $mod . "/start.php"))
          throw new PluginException(sprintf(elgg_echo('PluginException:MisconfiguredPlugin'), $mod));

    So basically there's an error when Elgg includes the mod/elgg_mobile_RC1/start.php file.  You'd need to figure out what is wrong with that particular PHP script.