How to create public contents?


On my new social networking site (, new users do not seem to have an option to flag their blogs and pictures "Public" contents. They only see "Private" "Friends" "Groups" in the Access drop-down list. Only Administrator has "Public" and "Logged in users" in addition to above.

How do I enable these two options for all users?

Many thanks,



  • @Daniel, you can set the default site access permissions to Public in the Admin > Site Administration settings menu.  Then it is up to your users to decide what level of permission is desired for their content. 

    There is another option to look for below this:

    If checked, individual users will be allowed to set their own default access level that can over-ride the system default access level.

    With the correct settings here you should be in business.

  • Hello Mark,

    Thanks for your reply. But even when I logged in as Administrator, I don't see "Public" in the list of default site access permissions in the Admin > Site Administration settings menu. Only "Private" "Friends" and "Groups" show in the list.

    I also checked Allow user default access tickbox. However, "Public" option is still not available in the drop down list.

    Appreciate once more your advice!

    Many thanks,



  • Hi Daniel, I do not understand this problem.  The standard installation has this option... when you generate Groups, these are added to the permissions list, but the starting point should be here.

    The only other things I can suggest is seeing if you get the options with the standard elgg theme, and to try reordering the plugins (they load in orser from top to bottom).. Good Luck :)