Upgrading - Scarey

I'm running 1.5, but need the 'settings' functionality that's included with the 'groups' mod from 1.6

I've tried removing the 'groups' mod that's packed with 1.5 and replacing with the 'groups' mod that comes with 1.6, but when I attempt to edit a group or create a new group, when I click save I get the following error message:

'Form is missing _Token or _ts fields'

Can anyone help?