Install Error Data direction isn't writeable.

I am doing a fresh install of elgg on Ubuntu Server.  I used ISPConfig to create the website and the database.  I keep getting this error message Your data directory /var/www/clients/client1/web35/elggdata/ is not writable.  I have read through many threads but still no luck.  I have edited my .htaccess file and removed the # sign in front of RewriteBase /.  I also performed mode rewrite test specified under the install troubleshooting and it's working fine.  I am looking for suggestions.

Thanks in advance

  • I have actaully done that throught the command line.  I set the permission to 777 and the ower of the folder is the same as the virtual host owner but still no luck.  The only way i seem to get something working (not fully) if i put elgg under another folder instead of default public folder and according to what i read if i create data folder in that situation that creates security issues.

  • I've installed on Ubuntu many times and never had a data directory problem. Why are you putting the data directory under /var/www/? That's not a good idea.

    You should also check that safe mode is not turned on for php but that should be off by default with Ubuntu.

  • yeah, the data folder should be outside of the main elgg directory.. if you are unable to go outside of the www directory with your host (godaddy shared hosting is like that) then your easiest option is to use a sub-directory for your main elgg install, and put your data folder outside of that... as long as it's not inline with your main install path, the installer won't complain.


  • I am totally new to web master stuff.  Actually I am not running on shared hosting..I have full control of the machine.   I have tested social engine and they had similar setup screens and it went without any problem.  I even followed a tutorial on how to install elgg with ispconfig.

    Cash..why the data directory is is under var/www...I am using ispconfig which created a virutal directory and everything is uploaded there that's why i created it there.  I have created the directory outside that path also but I will try that again.

  • I don't know anything about ISPConfig. On a clean Ubuntu server install, you only have to create the database (use phpmyadmin), edit the apache configuration to turn on mod_rewrite (set AllowOverride to All for /var/www), and create a directory for the data. From there, you're just following the instructions in the installer.

  • Thanks Cash and Studio1031.

    There's seems to be some issue with elgg doesn't work with elgg.  So I followed your (Cash) advice and learned how to create website under /var/www/.  The only issue was about creating database even though i created one using Webmin that didn't seem to work.  Then i just used Ispconfig and created another one and upated the settings.php under the engine folder and eveything else went smooth afterward.

    if anybody needs help here's the site i used

    I didn't create this file virtual.conf as mentioned in the article.   When the article says to created this file /etc/apache2/sites-available/  I created