No formatting in a new install of 1.6.1

Hope this is the right place for this. I have just installed 1.6.1 following the installation instructions in the documentation area. All went as described until I got to the login page and into the site. No formatting or structure to the pages - http://terrywassall.org/elgg/. You'll see what I mean if you look. Any ideas on what it is I need to do or have left undone? I have spent most of today searching for info on this and come up with nothing so far.

Whoops (update): after checking earlier messages in this discussion I tried changing to another view, choosing failsafe. Now I can't log in or anything! I'll look in the installation and db to see if I can change back to default view there. Any ideas gratefully received.

Further update: Sorry this is becoming a bit of a saga (appropriately enough). I found a line in the db where the view is specified, in the elggconfig table: view  = s:8:"failsafe";

I changed this back to view  = s:8:"default"; and I can log in again. But still no formatting or layout, as if no css or anything else is being applied. I don't like messing about in the database as I'm not sure what I'm doing.

  • I think I have fixed the formatting, lack of css, problem. I found this referred to in an earlier post in this forum http://docs.elgg.org/wiki/General_Troubleshooting. I turned the 'simple cache' off in site adminstration and immediately the formatting was fine! Turning the cache back on again immediately trashed the layout again. So I suppose I need to leave it off even though it says "Use simple cache (recommended)"