Admin Menu Missing..

Hi all,

After a long time I am active here.. Hope everyone doing fine..

I have a very peculiar problem after upgrading elgg to 4.3.9.. Administer Side bar menu is missing..

php version is 8.1

mysql 8.0.34 

  • i solved the issue.. one plugin was active

    Now i have a new problem.. /admin/statistics gives fatal error saying "elgg_delayed_email_queue" doesnt exist..



  • Looks like this came from some plugin that you no longer have or you haven't updated it.

    You can find this plugin and make updates.

    Or simply manually delete records about this entity from the database.

  • thanks for your reply.. I soloved that too.. I created a fresh installation and checked the db and found the new table elgg_delayed_email_que and imported this table to my original db which solved my problem..




  • Looks like you didn't run the upgrade process yet. As this would have created the database table.

    It'll also perform other database upgrades.

    You can run the upgrade process by going to your website https://yourwebsite.tld/upgrade.php or if you have access to the CLI on your server you can run the command

    vendor/bin/elgg-cli upgrade
  • I just upgraded to 5.0 from 4.3.9 but it showed a fatal error..

    my work arround was to comment out the line 21

    for notice I added '@' to unserialize($row->value)

    [12-Oct-2023 17:02:41 Asia/Kolkata] [2023-10-12T17:02:41.757727+05:30] ELGG.NOTICE: PHP NOTICE: 2023-10-12 17:02:41 (IST): "unserialize(): Error at offset 2 of 36 bytes" in file D:\webserver\www\sanchar\vendor\elgg\elgg\engine\classes\Elgg\Database\ConfigTable.php (line 144)  {"process_id":7296,"memory_peak_usage":"18 MB","memory_usage":"18 MB","url":"/admin","ip":"","http_method":"GET","server":"","referrer":null}
    [12-Oct-2023 17:02:44 Asia/Kolkata] [2023-10-12T17:02:44+05:30] ELGG.CRITICAL: Exception at time 1697110364:
    elgg_view_message(): Argument #2 ($body) must be of type string, null given, called in D:\webserver\www\sanchar\vendor\elgg\elgg\views\default\object\admin_notice.php on line 21
      {"backtrace":[],"process_id":7296,"memory_peak_usage":"22 MB","memory_usage":"22 MB","url":"/admin","ip":"","http_method":"GET","server":"","referrer":null}
  • please see my previous comment.

    Did you (after upgrading to Elgg 4.3.9) run the upgrade? Because it looks like some database values weren't converted to the correct format. One of the upgrades should have done this in the 4.3.9 upgrade (i believe).

  • thank you jerom, I just found there are not upgrades pending at /admin/upgrade/

    but while running elgg-cli there are 3 pending upgrades shows.. I am posting that here..

  • Completed upgrades                                                                                      
    | Elgg\File\Upgrades\MoveFiles                          | Move Files                            |        
    | Elgg\Upgrades\ContentOwnerSubscriptions               | Add content owners to the subscribers |        
    | Elgg\Upgrades\ChangeUserNotificationSettingsNamespace | Migrate user notification settings    |        
    | Elgg\Upgrades\DeleteDiagnosticsPlugin                 | Remove the diagnostics plugin         |        
    | Elgg\Upgrades\DeleteNotificationsPlugin               | Remove the notifications plugin       |        
     Pending upgrades                                                                                        
    | Elgg\Upgrades\AlterDatabaseToMultiByteCharset   | Alter database encoding for multi-byte support     |
    | Elgg\Upgrades\MigrateACLNotificationPreferences | Migrate Access collection notification preferences |
    | Elgg\Upgrades\NotificationsPrefix               | Migrate notification subscriptions                 |
    | Elgg\Upgrades\RemoveOrphanedThreadedComments    | Remove orphaned threaded comments                  |

    these pending upgrades are not showing in admin/upgrades/


  • @jerom Bakker,

    I just started over again from the scratch. from Elgg 1.18 to 4.3.9.. Now every thing work fine.. No php errors are generated. thank you so much

    Important Info :

    1. elgg_delayed_email_queue was not created after upgrading to 4.0.. I copied the table from a fresh installation

    2. after running elgg-cli upgrade:list following result obtained.. I ignored it, because there may not be any threaded comments.


    | Elgg\Upgrades\NotificationsPrefix                     | Migrate notification subscriptions                 |
    | Elgg\Upgrades\MigrateACLNotificationPreferences       | Migrate Access collection notification preferences |
    | Elgg\Upgrades\ContentOwnerSubscriptions               | Add content owners to the subscribers              |
    | Elgg\Upgrades\ChangeUserNotificationSettingsNamespace | Migrate user notification settings                 |
    | Elgg\Upgrades\DeleteDiagnosticsPlugin                 | Remove the diagnostics plugin                      |
    | Elgg\Upgrades\DeleteNotificationsPlugin               | Remove the notifications plugin                    |
    | Elgg\Upgrades\AlterDatabaseToMultiByteCharset         | Alter database encoding for multi-byte support     |
     Pending upgrades
    | Elgg\Upgrades\RemoveOrphanedThreadedComments | Remove orphaned threaded comments |