multisite plugin and core files for elgg 1.5 and elgg 1.6.1


I have just uploaded the new version of the multisite plugin.

It includes some bug fixing and a few new features

The major one is the implementation of a full local admin role :

- Local admins now have the same permissions than the admin on the groups and objects of their community. (update, delete)

- A new gatekeeper function is introduced for actions that can be used by admin and local admins : multisite_admin_gatekeeper()

- Local admins now get an extra menu on users profile pages and icons, similar to the admin one, that allows them to ban/unban, edit details, reset password, make/remove localadmin

I already use this plugin in productions sites. But i better say that you need to test it on your own installation before running into production.  I hope not but  there should be still a lot of situations that i have never been into and which could lead into problems.

Thanks to Chrisn Deon and the others who have reported bugs and sometimes solutions for the previous version

Thanks to Alivin for his work on elgg1.6 and his ideao to allow users to switch from a community to another without relogging

the file is there - Please follow instructions on the readme file to install it

And again, please, share your questions and experiences on this forum


  • @Devel95  well  i get a full elgg login page there :)  with your photo azs a newest member .... did you do anything ?

    By the way did you intall the 2.2.3 version of multisite ?

  • You are correct about connecting to our ellg install. I reinstalled and cleared all cache and I am back to 1.6.1. I did not have to mess the the DB.

    Plus, I had backed out both MB 2.3.1 and MB 2.3.2

    I am taking a full backup (again) of my elgg directories, then I plan to proceed with MB 2.3.2.

    I'll post results here shortly.



    Yes, installed MB 2.3.3


  • That's what I used. Did it change in the past 1.5 hours?

  • @Devel95   No version 2.3.3 hasn't changed

    i suggest that you do it step by step :

    1) start from a running 1.6.1 installation

    2) disable all the third parties plugin (those which are not include in the elgg standard distribution)

    2) enable the multisite plugin and see if you get a blank screen

    3) go to the admin->community menu and run the init process (dont forget to complete the subfolder field) - refresh your browser and see if you get a blank screen

    4) replace the /engine/lib files from the elgg16 folder of the plugin + the simplecache/view.php file  + the /engine/start.php file  - refresh your browse and see if you get blank screen

    5) unlog and see if you get a blank screen

    6) login and see if you get a blank screen

    7) re-enable the third party plugin one after the other

    Let me know at which of the  steps above you get the white screen pb

  • Ok, will do first thing in am. It is 16:55 (GMT-5) and I have an evening appoinment so I need to leave the office on time today.

    Q: the only plug-ins I downloaded and installed were Calendar Events and Spanish Language. Would any other plug-ins constitute a 3rd PTY?

  • GregKeys

    Tried this version and if the subdomain is left blank it removes the domain from the URL on the create new community if I fill in the subdomain with the actual domain it shows the domain properly in the create community however when I try to create a community it gives me an error stating to run the init multisite, which I have done after every change.


  • @Gregkeys   YOu get the message asking to run multisite when there is no domain value as input data.

    So you can do this to go back to a better situation :) :

    - if your installation is not running under a subdomain, leave the subfolder field blank, fill in the domain field and run init againt

    - go to admin->communities->communities setting and select the community which is active at this moment (the one you are running in)

    - set the domain value with the correct domain name

    - Save and now you can create a new community form there, it should get a correct url

    let me know

  • GregKeys

    It worked except that I can not delete the subdomain value, I can change it but I can't delete it, elgg simply refills it back in once saved.