Website Migration

I am forced to migrate my website safalaya.com from php5.6 to php 7.2 . I am using elgg - 1.8.19 . php 5.6 is depriciated .

  • Elgg 1.8 will NOT work on PHP 7!!!!

    You need to upgrade at least to Elgg 2.3 to be able to run it on PHP 7. You need to upgrade to Elgg 2.3 when your server still runs on PHP 5.6 because only with version 2.3 Elgg became compatible with PHP 7 (while Elgg 2.3 still working with PHP 5.6).

  • And to make it clear: you can't upgrade directly from Elgg 1.8 to 2.3.

    You need to upgrade from 1.8 to 1.9 then 1.10, 1.11 and 1.12. Only from Elgg 1.12 you should be able to directly upgrade to Elgg 2.3 then. Don't forget you also need to have compatible versions of 3rd party plugins matching to the Elgg version respectively.

    Well, you had a few years to think about that I would say...