MySQL Credentials did not take from web page

Just an FYI to the developer(s)...the install web form did not save my MySQL credentials. I had to manually enter them into the settings.php file.

  • You need to grant write access to the engine directory or the code can't create the settings.php file.
    This is explained in the INSTALL.txt file that comes with Elgg - definitely worth reading carefully.

  • Ok, thanks Kevin.
    I think you are referring to Step 5 in the INSTALL.txt file. I followed it very closely and there is specific no mention of "needing to grant write access to the engine directory". I ended up hard coding the settings manually in the settings. php file per the instructions.
    Here is an excerpt of the verion of the INSTALL.txt file that came with 1.6.1:
    If these files can't be automatically generated, for example becauseyou don't have the correct directory permissions, Elgg will tell youhow to create them. If, for some reason, this won't work, you will need to:    * Copy engine/settings.example.php to engine/settings.php, open       it up in a text editor and fill in your database details
    If the developer is reading this post, there may be an opprtunity to re-word the INSTALL.txtx file to be a bit more clear and exact.