Plugin can not be activated

Hi All,

I have developed a plugin and it works on my windows environment.

When it is enabled, it shows the message "Plugin enabled successfully" but looking at the tool administration, it remains inactive???

Can anyone tell me why? 

I have created a few simple plugins, and never came across this problem.  I tried disabling ALL other plugins and still no luck

Please help!!!

  • what do you mean by "inactive". Does the button still say "Enable"?

  • Enable - Yes it does.  It turns out there is an old plugin of the same name that I must have deleted not in the correct manner and it still exists in the system.  The only difference between the two plugins is the uppercasing in the letter. ie "Orange" and "orange"

    However, I tried to delete it changing the plugin disable script.  Although successful, when i revert to my new plugin, enabling "orange", it reverts back to the old plugin name, "Orange".  

    This is causing problems and somehow, the database is still noticing "Orange".  How do I permanantly delete the plugin "Orange"???

    Thanks for ur help