Installing version 4.0.2 via cli

I tried to install a new instance of elgg via the recommend command line method and failed. It did work with downloading the file however.

The error after vendor/bin/elgg-cli install was:

In NativeSessionStorage.php line 150:
  Failed to start the session because headers have already been sent by "/Sites/org.example/vendor/tedivm/stash/src/Stash/Utiliti  
  es.php" at line 212.

Install on macos 11.6 with nginx and M1 

  • A quick look in the code, this looks like a filesystem issue.

    • Did the dataroot folder exist you provided in the installation steps?
    • Are the permissions for that folder set correctly?
    • What PHP version are you using?

    If you still have problems could you maybe log the issue in GitHub that way it's easier for us (the core developers) to help you.

  • The dataroot folder did exist.

    It had 755 permissions.

    PHP 8.0.12

    Going the route with the download instead of the command line solved the problem.

    Will post to github issues from now on.