upgrading from 2.3.17 to 4.0

I got the error 

- elgg/elgg 4.0.0 requires npm-asset/components-jqueryui ~1.12.1 -> no matching package found.

how do i remediate this issue, I saw on one side it said to delete vendor, but that seems like the whole elgg site. I'm very new at this stuff and working with tech support to address this issue. 

Thank you.