Database setting causing "Call to undefined method ElggObject" error in code

Weird problem in Elgg 1.9.7...

Using Matt Beckett's rssimport plugin, everything works perfectly on my dev machine but not on a test machine, with a very slightly different database: the dev machine uses a copy of the production DB taken a few weeks before the one used on the test machine.

In itself this would not be surprising, except that the error I get with the non-working database is in the code itself:

Fatal error: Call to undefined method ElggObject::getFeed() in /usr/libexec/elgg197/mod/rssimport/views/default/resources/rssimport/import.php on line 56

This method is a) defined and b) runs perfectly using a different database. Switching to the database copied from my dev machine (simply changing the DB in settings.php - exactly the same code base, only the db is different) everything works as it should. The databases were each (separately) upgraded from 1.8.20, with no apparent problems.

The thing that is puzzling me is that I cannot think of anything in the database that could possibly cause a method to be undefined in the code itself, especially when it works perfectly well with a very similar database.

The plugin order and activation is identical. As far as I know, the settings for all the plugins are the same, though it is possible some could vary very slightly - I've checked most of them but, as they started from the same database, they should be pretty similar. The settings for the rssimport plugin itself are identical.

Has anyone come across a similar issue in any plugin before? Any clues appreciated!



  • Following up -

    The problem is fixed. I disabled all non-bundled plugins, enabled the plugin on its own, it worked. I re-enabled the plugins and it still worked. I can't make it fail any more.

    I am mystified.

    The only thing I can think that it must have been is a cache issue, but caches are disabled via developer tools plugins. Unless there's a cache on the webserver, perhaps, but the server has been restarted since the problem occurred, so that seems unlikely.


  • RSS Import uses Simplepie library which creates cached RSS requests and stores them in the /data directory.


    The only thing I can think that it must have been is a cache issue, but caches are disabled via developer tools plugins

    This could be the reason of your issue