Fatal Error with File Tools plugin

I tried another plugin File Tools. When I go to upload files that is supposed to trigger File Tools, it returns a Fatal Error as well. Now, I have only tried two external plugins, File Tools and LMS Tutor, and both have resulted in Fatal Errors and the authors of both plugins have not responded to me. Is this the state of Elgg overall? Or is it the state of just the plugins? Are all plugins not reliable for me to use in production? Is Elgg reliable for me to use in production. As a newbie I am really losing confidence. Would appreciate any and all input on the specific problem and my overall concern.
 

Fatal Error.

Call to undefined function elgg_load_library()

Log at time 2020-12-23T23:26:11-05:00 may have more data.

 

#0 /home/alec/public_html/elgg/vendor/elgg/elgg/engine/classes/Elgg/ViewsService.php(516): include()
#1 /home/alec/public_html/elgg/vendor/elgg/elgg/engine/classes/Elgg/ViewsService.php(449): Elgg\ViewsService->renderViewFile('resources/file/...', Array, 'default', true)
#2 /home/alec/public_html/elgg/vendor/elgg/elgg/engine/lib/views.php(404): Elgg\ViewsService->renderView('resources/file/...', Array)
#3 /home/alec/public_html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Router.php(280): elgg_view_resource('file/upload', Array)
#4 /home/alec/public_html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Router.php(128): Elgg\Router->prepareResponse(Object(Elgg\Http\Request))
#5 /home/alec/public_html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Router.php(104): Elgg\Router->getResponse(Object(Elgg\Http\Request))
#6 /home/alec/public_html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Application.php(479): Elgg\Router->route(Object(Elgg\Http\Request))
#7 /home/alec/public_html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Application.php(360): Elgg\Application->run()
#8 /home/alec/public_html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Application.php(416): Elgg\Application::route(Object(Elgg\Http\Request))
#9 /home/alec/public_html/elgg/index.php(8): Elgg\Application::index()
#10 {main}
  • I think you're using the plugin on a version of Elgg which isn't supported by the plugin.

    File tools isn't compatible with Elgg 3.x, because we haven't had a need for it to be updated.

    If you wish for it to be updated contact us at info@coldtrick.com and we can discuss what would be involved to update the plugin (time / costs).