Blog on 3.3.0 failing to be seen as public

I saw a post in the technical section on this but for some reason couldn't reply.  I am guessing it is due to that technical section of discussions needing a specific password?  

3.3.0 has been great in just about every way but I am having trouble with the blog section.  No matter what setting I use after writing a blog post the posts seem to always come out as private.  I have selected public but when clicking save it still comes out as private.  Has anyone else experienced this?  Are there workarounds for this?


thanks, Tom



    Great to hear!  In the admin when I go to "Upgrade" it tells me "The site has pending upgrades that require your immediate attention.  View pending upgrades"  But when I click that link it says the site is up to date. My present version is 3.3.0

    Does this require a manual upgrade somehow or can it be accomplished in the admin section?  

  • In first, you need a new version ;)

    How did you install your current Elgg: via composer, or unarchive ZIP and copy files to server?

  • I uploaded the zip file to the directory and then extracted.

  • Now download a new version, unarchive and replace folder/files.

    After uploading run Upgrade via Dashboard.

    Please, read this and this before upgrading.

  • Thanks for this RvR.  Looks like they are recommending Composer. I think that requires command line access and I am not sure I have that.  I have elgg now in public html, what would happen if I uploaded the zipped 3.3.1 to the same public html dir and then extracted?  Would it create problems?  If so, are there specific folders that have changed for 3.3.1?  Would it be possible to only change those folders?

  • Use 'legacy' method only not composer as provided in the links above.

    1 - Backup DB and root installed Elgg. You may not backup 'data' folder; it will not upgrade.

    2 - Look at the user:group owner's rights permissions on your folders/files. Remember it.

    3 - Login as Admin -> Go to Dashboard->Site settings and disable all enabled caching' options (simple cache and system cache).

    4 - Return on the Dashboard and stay there.

    5 - Now unarchive the downloaded on your local machine and using FTP or something else (for Windows OS is WinSCP) copy all folders/files to your root installed Elgg directory over the existing folders/files. (Read the mentioned docs again).

    6 - After replacing new folders/files you need to check user:group rights permissions on its and change these if you need, e.g.:

    cd /home/public/html/
    chown -R user:group www

    Where www is my Elgg installed root directory and /home/... is a located my Elgg (data and root both)

    7 - Run Upgrade via Dashboard and Enable all caches

    8 - Done.

  • Thanks RvR.  That seems to be a significant PIA.  Since I don't have any users at this point I wonder about it being easier to start a fresh install and copy over the changes I made to the first installation.

    Will it work to have two installations of elgg running on the same host? Both with their own data dir and db?  If so, I could install fresh and then copy and paste what I have done over to the new installation. Would that work?

    I will eventually be putting this on a new web host and will be certain to have command line access.  Will learn Composer.  lol  

  • If you want to use the existing data and DB then you must use the duplicate installation. But it's not a fresh installation.

    If you made changes in the files (plugins but not /vendor) only and loosing all data and DB isn't important for you then I suggest this step-by-step guide:

    1 - Make new environments for your clean Elgg installation.

    2 - Try to use composer installation. It will help you in future to upgrade your Elgg w/o headache.

    3 - After installation you can copy all changes safely from old to new Elgg.

    Try it on this weekend; learn docs and happy elgging ;)

  • Thanks RvR.  I didn't have command line access so I simply installed another elgg and copied the changes I had made from the old site to the new.  Since I had no users this was simple and took very little time.  The next time I install elgg it will be with composer on a site that has command line access.  Thanks for your help with this. 

    oh, and yes, the blog works now!  Tom