Cannot delete user with admin - file plugin problem


I have a user that I cannot delete with the admin. When I try I get this error:


Filestore not found or class not saved with file!

There seems to be a problem with this user’s database because there are missing photos and file uploads. I was able to remove the blank photos but whenever there is a view of the file uploads I get the same error as above. Example, if I am a user other than the one I want to delete and I go to "site file" uploads, I get the above error.

This is in my /mod/file/error_log:

[09-Oct-2009 02:16:56] WARNING: 2009-10-09 02:16:56 (EDT): "Invalid argument supplied for foreach()" in file /home/tautolog/public_html/network/mod/custom_profile_fields/start.php (line 39)

[09-Oct-2009 02:16:56] *** FATAL EXCEPTION *** : exception 'ClassNotFoundException' with message 'Filestore not found or class not saved with file!' in /home/tautolog/public_html/network/engine/lib/filestore.php:652

Any ideas how I can solve this?

Manually remove user?



  • Ok, I know this has to do with the "file" default plugin. I would like to delete any entiries of this users file uploads - Does someone know the Object ID of a file upload. I thought if I knew this then I would delete them in the database.


  • This is how I solved it:

    I noticed in the database there was a table called subtypes and "files" is subtype 1. I then removed all of the specific user guid in table entities that had a subtype of 1 and everthinig works again.


  • hi,

    i am having same problem. I followed up your solution and found out that there are no etries at all  in entities table with subtype 1 for guid (which i want to delete). Please advice me.


  • I have the same probleme. I wanted to upload some photos, but as result i obtained this messages: CLASSNOTFOUNDEXCEPTION

    Filestore not found or class not saved with file!

  • I have disabled tidypics plugin and the site works again, but when i enable it, same message: 


    Filestore not found or class not saved with file!

    What can i do to repair this and to keep tidypics plugin enable?

  • Here are the details behind this error message:

    Every ElggFile or TidypicsImage is stored in a filestore (almost always on your server's disk). The information about the location of the filestore is stored as metadata on the ElggFile entity. The two pieces of metadata of interest here are filestore::dir_root and filestore::filestore. It looks like you have a TidypicsImage with bad metadata - basically, the image does not have any filestore::filestore metadata. 

    Why does this happen? I have no idea. It certainly is not reported often. Manually editing the database? Server crashing during a write operation?

    How to recover? Two options: delete the entity that has the missing metadata or create the missing metadata. Much easier to delete the bad entity in your database.

  • Thank you verry much, Cash!

    I deleted the bad entity in database and now everiting is working again, even tidypics!

    I was disperated...

    God bless you!!!

  • how do i delete the bad entity? i tried removing the tidypics plugin (so i could login) and then deleteing the user using the admin option in the user's drop down menu. this then told me i had deleted the user but!...

    when i re uploaded and re enabled tidypics, this error returned: Filestore not found or class not saved with file!

    i have had to delete tidypics until a solution can be found. i am running elgg 1.7.1

  • nevermind lol, started over with a fresh db.

  • For the record, the filestore problem has been corrected in 1.7.2.