Cannot publish blog post & Unicode incompatibility with Elgg 3.3.0

Please post any working or demo link of Elgg 3.3.0 site if you have.

While testing it on actual server, I am finding the following problems as I start the testing

Cannot save blog post as published, even though published option chosen. It always become draft
Comment box not seen although I have set comment behavior just like Elgg 2x via admin site settings

Unicode name incompatibility ( I did this with "admin" but you can test with any user I guess) : Steps to reproduce

Go to mysite/elg3x/settings/user/admin

  • Change username to unicode characters देवनागरी
  • The system allows it
  • When you hit save, you get error message : "Invalid argument exception"
  • You again hit save, thinking it will save this time
  • you get another error message : "Error  You do not have sufficient permissions for this action."
  • Now if you visit the admin account mysite/elg3x/user/view/49 (or whatever number this is) - you get another error message "Error The page you are trying to view does not exist or you do not have permissions to view it"
    Basically you cannot get back to the account

All testings done with core and default Elgg just out of the box in php7x environment. No such problem with Elgg 2x so far. I will like to post github issues but need to know from fellow-Elggers if they are also facing similar problems in Elgg 3.3.0 sites. Thanks.

  • Cannot save blog post


    Unicode name incompatibility

    Seems there's a bug to validation username.

    I believe that you can't use these characters in your username but something is missed in Elgg blacklist for bad characters.


    Please, open 2 issues on GitHub with link to this discussion.

  • I can use these characters without any problem in Elgg 2x. Thus, whether using Elgg 3x new or upgrade from 2x to 3x, these accounts will become inaccessible at certain points or fully. Many thanks for your response.

    @RvR Could you reproduce the steps Unicode name incompatibility in Elgg 3.3.0?

  • I can use these characters without any problem in Elgg 2x. 

    In the field 'Display name' but not 'Username'.

    Edit: My bad. Really, you can register with this username in Elgg 2 and Elgg 3.3

    But viewing and changing the username in Elgg 3.3 calls the mentioned error.

    Could you reproduce

    Of course, i did it already before posting my reply.

  • Thanks RvR

    After I did the above steps of changing admin username to an unicode charcters name, things did not work and I did revert to the same english name "admin". But now after logging out, I cannot enter the site with username "admin". There is NO error message also. Just the log in page remains.

    I tried to enter the database and see if I can change anything manually. I found that although I have only one and only one user "admin" in database tables there are three users. Confused!


    Full texts id entity_guid name value value_type owner_guid access_id time_created enabled
          37 49 admin yes text NULL NULL 1580066880 yes
          42 49 username admin text NULL NULL 1580066880 yes
    Edit     44 49 name admin  


    PS : cannot logiin to github just at this moment as they have started some new complications :"Device verification code" making login so convoluted. If anyone can post these issues for an urgent patch, it will be great as with current scenario latest Elgg 3x is practically unusable (unicode users cannot use, blog post unpublishable). Will try to post to github when and as soon as I can login there.

    PS2: any guide or knowledgebase article ( I cannot find) how to create admin directly in database table with password via phpmyadmin or similar to save our soul  SOS in such situations?

  • You have 1 user (look at 'entity_guid' column) with 3 metadata.

    Username of admin is correct in your DB:

    49 username admin


    Don't try to create admin directly in DB.

    If you have any registered user then find its GUID 'entity_guid' in DB -> name 'admin' related to this guid -> change value 'no' on 'yes'.

    Now you have new administrator on your site.

    I'll open issues ASAP.