SQLSTATE[42S02]: Base table or view not found: 1146 Table 'elgg.elgg_config' doesn't exist

Using the latest stable version of Elgg on Centos7.  I've tried installing both through the elgg-cli and through the browser.  With each I get the error stating that 

I saw this was an issue on github and also saw that there was a fix merged, however it still seems to be an issue.  I've used all of the correct credentials/permissions and have verified that I can access my database.

In Database.php line 448:

An exception occurred while executing 'SELECT * FROM elgg_config': SQLSTATE[42S02]: Base table or view not found: 1146 Table 'elgg.elgg_ config' doesn't exist

install [-c|--config [CONFIG]]


  • sorry.. I meant I created the elgg database, not the "table" (it was late) and then I created a user with privileges.  The only difference I see on my configuration is that I'm connecting to a remote google cloud instance for my database, not localhost, but I've verified that I can connect successfully from my elgg instance.  I'll take a look at the video just to make sure I'm doing things correctly.. 

  • I create the table within my within MySql using CREATE DATABASE elgg;

  • Ok.. so here is information that I believe would be relevant.  I had this same error message appear when I tried to install version 3.1.1 almost 2 months ago.  I never resolved and had to revert to version 2.3.14.  When I followed the instructions on that version, it was a seamless, error-free install.  I wanted to try the latest version because I saw a thread on github: https://github.com/Elgg/Elgg/issues/12809 so it seemed this actually was an issue that was resolved.  But, for some reason that I still can't figure out, it still shows that same error for me.

  • Yes, all of my DB settings are correct.  I'm using MySql 5.7 and all innodb* settings match.  However, there is a slight difference in the character set.  I'm using utf8 not utf8mb4... but would that really make a difference?

  • Thank you for your help.. I've pretty much given up on using the latest version for now.... in a time crunch.  Reverting back to using version 2.3.14 since I don't have the issues with using that version.  Again, I appreciate you patience and time.. I know I was probably starting to annoy you a little with the questions.

  • A few days ago, I proposed this solution, and it helped.

    Perhaps, this case is yours too (•◡•)