Questions about the latest version

Does anyone here use the latest version, 3.1.5? is this version good or not?

  • it's the best version of Elgg 3.x ;)

    What kind of answer do you expect thinking about your question a few days ago

  • Yes I hope this is the best version. But will it support existing plugins? because if I pay attention the plugins that are here only support versions 2.3 and 3.0

  • There are fewer plugins available for Elgg 3 than there are for Elgg 2. As the plugins written for Elgg 2 won't work without changes on Elgg 3 in most cases you can't use the plugins not yet compatible with Elgg 3 on any Elgg 3 version.

    Now it depends which plugins you need - and if you really, really need them - if it's an option for you to start without these plugins for now and start with Elgg 3 or if you need these plugins in any case and therefore have to start with Elgg 2.3 for now. If the plugins are updated to work on Elgg 3 you can upgrade your site at that time. But it's kind of impossible to give any timeline when developers might publish updated versions of their plugins. For example, I would have thought that I would have finished upgrading all the plugins I maintain already but I just haven't found the time yet. With some other developers it might be the same. But in some other cases the developers might have abandoned their plugins and won't make any further releases anyway. So, it depends on the plugins you need / want to use what Elgg version would be best to use.

  • thanks for the suggestion, it was very helpful in my opinion. before I used elgg version 2.3.14 because there are many plugins that can be used, but I want to try this latest version whether it's good or not

  • Use 2.3.14

    As I stated in the previous thread,  there are far more plugins available (and functional) for the LTS release. If you really want to know which one is better for you, I suggest you to:

    • Gather all your requirements
    • Use elgg and see if it meets the majority of your needs
    • Check if some of your requirements are met by using plugins
    • Check if those plugins you need are available for 2.3.14 and for 3.x