Database error when intall

"There was an error creating the Elgg database and installation cannot continue. Review the message above and correct any problems. If you need more help, visit the Install troubleshooting link below or post to the Elgg community forums"

I use xampp server

PDO is ok

Permission is ok

 

Plis help!!

 

 

  • tried RM settings.php and copying "/vendor/robmorgan/phinx/"

    Got this on install attempt, which is new, looks a lot like the problem in 3.0. it only writes "elgg_migrations" table to the DB.

    Oops...

    • Database has been installed.

    Oops...

    Error
    An exception occurred while executing 'SELECT * FROM elgg_config': SQLSTATE[42S02]: Base table or view not found: 1146 Table 'xxxxxxxxx.elgg_config' doesn't exist
  • These releases include the outdated cakephp/phinx version with fatal error.

  • Just copy files Phinx 0.11.1 to /vendor/robmorgan/phinx/

    Works for me, tanks RvR!

     

  • I finally got around to trying again.

    downloaded the zipped elgg3.1.5
    running win ampps3.8, php7.1

    installer failed at:
    "An exception occurred while executing 'SELECT * FROM elgg_config': SQLSTATE[42S02]: Base table or view not found: 1146 Table 'XXXXXXXXXXXXX.elgg_config' doesn't exist"

    ~removed /elgg-config/settings.php
    ~rebuilt DB
    ~downloaded phinx-0.11.1 GH zip extracted contents of phinx-0.11.1 to vendor/robmorgan/phinx

    ~Tried again
    installer failed at:
    "An exception occurred while executing 'SELECT * FROM elgg_config': SQLSTATE[42S02]: Base table or view not found: 1146 Table 'XXXXXXXXXXXXX.elgg_config' doesn't exist"

    it creates 1 empty table "elgg_migrations" in th db.
    I am doing a fresh install.

    Last time i tried to install a few weeks ago I went down the road trying to fix this phinx thing through composer, but I am increasingly convinced that cake/phinx is not the problem I am experiencing.

    I haven't tried the CLI install or cloning this time, but it all went to the same errors last time so I have no reason to expect different results trying those install methods...

    Thanks in advance if anybody has some info on this.

  • Haha, silly me, looks like phinx-0.11.1 is in the build, but that did not help my problem. Can anyone confirm a fresh install, I ask because I suspect most of you have been merging updates, rather than running fresh installs?

  • Can anyone confirm a fresh install

    Confirmed on:

    - Ubuntu/Nginx/PHP 7.1/Maria DB 10

    - Debian 9/Nginx/PHP 7.3/Maria DB 10

    - Windows 10/Apache/PHP 7.3/MySQL 5.7

    Tried CLI (composer install) and web interface (browser) both.

  • Thanks, guess I'll try on a remote Linux later.

  • Solved: After confirming the phinx package updates in 3.1.5, it became obvious that I had a different issue going to the same error message. I eventually hit an informative error message while doing something else. "innodb_force_recovery" was commented in ampps conf\my.ini from a previous issue and preventing writes. -> as a related question; Is there a method to disable elgg's error interception?
    Thanks for confirming the installs, that helped a lot.