Plugins Incompatible with PHP 7.2

Dear Elgg Community Experts and Plugin Developers,

There are some plugins which are not compatible with PHP 7.2. The following are some lists

1. Block Users  by Arck Interactive
https://elgg.org/plugins/2380396

2. Security tools  by Jerome Bakker
https://elgg.org/plugins/1941178

3. View Counters by Ismayil Khayredinov
 

The above plugins work perfectly with php 5.6 + - 7.0,  Can the respective author of the above plugins release php 7.2 compatible version or tell me how to fix it?