Elgg Fatal error


I just downloaded Elgg to my web server, but when I try to install it, I have a fatal error:

Fatal error: Uncaught TypeError: Argument 1 passed to DI\ContainerBuilder::setDefinitionCache() must be an instance of Doctrine\Common\Cache\Cache, instance of Elgg\Di\DefinitionCache given, called in /var/www/html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Di/ServiceProvider.php on line 328 and defined in /var/www/html/elgg/vendor/php-di/php-di/src/DI/ContainerBuilder.php:196 Stack trace: #0 /var/www/html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Di/ServiceProvider.php(328): DI\ContainerBuilder->setDefinitionCache(Object(Elgg\Di\DefinitionCache)) #1 [internal function]: Elgg\Di\ServiceProvider->Elgg\Di\{closure}(Object(Elgg\Di\ServiceProvider)) #2 /var/www/html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Di/DiContainer.php(69): call_user_func(Object(Closure), Object(Elgg\Di\ServiceProvider)) #3 /var/www/html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Di/DiContainer.php(49): Elgg\Di\DiContainer->build(Object(Closure), 'dic_builder') #4 /var/www/html/elgg/vendor/elgg/elgg/engine/classes/Elgg/Di/ServiceProvider.php(320): Elgg\D in /var/www/html/elgg/vendor/php-di/php-di/src/DI/ContainerBuilder.php on line 196


I use a fork of Debian and NginX. The adress of the website is: https://www.dscvr.cf/

I followed the tutorials steps well, but it didn't work. I even reinstalled ELGG and updated PHP and its extensions, but it still doesn't work.

I can't even access the installation steps.


EDIT: I leave you a screenshot.

  • I faced similar issue in my local (EASYPHP) with Elgg 3.1.1. Though Elgg 3.1.1 works fine on my Nginx Debian setup.

    For Local I used Elgg 3.0.6 and it worked fine. May be you can try that version for now and see how it goes

  • Hello

    Check the requirements for Elgg 3.

    I fixed a similar issue after using PHP 7.1+