Community Plugins all cause problems


I have recently implemented an ELGG social network and it seems to run fine.  I have added all of the standard plugins and they seem to run fine.  However, when I try to add a theme  or a plugin from the community, I get errors with each one but not the same for any.

I have downloaded and installed "tidypics" and when I do, I get an error screen that says "tidypics is a misconfigured plugin." with a length "PluginException Object" following.  I have no way of getting past that screen.  Even if I use a different browser, I get that screen and no way to log-in.  The only way to get control again is to delete the tidypics folder from the server.

I have tried adding the following themes with the following results:

 elggbook:  green notification window won't close, "Tools" link doesn't work, Wigits don't find content

theme_elgg_example: same problems as elggbook

theme_simplebliuewhite: seems to work OK

theme_simpleblackbluetech: mouse-over "tools" presents a transparent drop-down menu which is terribly formatted (can't be intentional).  Pages such as "members" are similarly jumbled.

theme_bluerounded: Top level menu (Dashboard and Tools) is non-existent

themer: presents a page full of text after enabling, back button clears it.

I bring this up because the errors are so prevalent, I wonder if perhaps there is a syste-level problem with our server or if there is a problem with the core implementation of Elgg.

Any insight would be greatly appreciated



  • Tidypics is a solid plugin so you must have installed it incorrectly. The Elgg documentation has plenty of information about that error.

    The themes that you have installed are for Elgg 1.5 and don't work for Elgg 1.6. Unfortunately, Elgg has done some not so smart things with themes which make them break very easily. You should be able to get the themes to work by deleting this file in the themes: /views/default/page_elements/header.php


  • As you say, this is not an error in Elgg but something specific with your configuration.  It sounds like the way you're uploading the files might not be working correctly.  Check to make sure that you're uploading a single folder to the mod/ directory.  In that folder, there should be at minimum a start.php and a manifest.xml file.  If you see tidypics/tidypics/start.php it has been uploaded incorrectly.

  • @Cash I might sound like a broken record, but generally themes won't break if you don't override header.php.  Unfortunately the example theme does this, so it encourages theme writers to do the same.  The views system isn't to blame for this as much as (understandably) misguided 3rd party developers.

  • That's exactly what I meant (which is why I instructed him to delete the header file in the theme).

  • themer: presents a page full of text after enabling, back button clears it.

    Sorry, I haven't been on - my schedule's been real crazy the last 2 weeks.  This week's no exception but stumbled upon this.

    The text display after enabling themer only happens the time themer is enabled by the system admin - I think it is a result of the server coming back with results before all the changes are made as this modifies the behavior of CSS which influences all the page formatting.  Perhaps I can put a sleep timer for a second or two somewhere.

    Version 0.3 is almost ready... perhaps another week, although I haven't address this text issue with that release.


  • Betty Jones

    elggbook theme problem can be easily solved .

    1. Try to delete the header.php file from the page_elements folder of the theme.

    2. Replace the header.php file with the original header.php

    If you are using the elggbook theme (elgg 1.5 comp) with elgg1.6,  you need to replace the header.php with original header.php file from the views folder , delete the js folder from the theme path views folder.

    ELGGBOOK THEME will work fine now.. my friend