Installation of Elgg 2.3.10 via Composer (git fetch issue, PHP 7 requirement)

Hi all,

I tried installing 2.3.10 with composer on Debian.

I hit two potential issues

1- For some reason, it gave a message like "cannot fetch from git, used repository version instead".

2- After the installation, when I visited the site, it failed in the requirements saying that "Elgg requires PHP 7.0.0 or above. This server is using version 5.6.40-0+deb8u1.". I thought PHP 7 was a requirement for Elgg 3.x ?  The documentation states the requirement as PHP 5.6+

Any idea as for what was wrong?

Thanks in advance.


  • Unfortunately, the instructions at are no longer fully correct. They were written when only Elgg 2.x was available and at that time the master branch was Elgg 2.x. But now the master branch is Elgg 3.x already and therefore you would get Elgg 3 installed when following the install instructions. That's also the reason why you get the error about PHP 7 because the Elgg 3 branch was downloaded by composer and as you said Elgg 3.x requires PHP 7.x.

    If you change the command

    composer create-project elgg/starter-project:dev-master .


    composer create-project elgg/starter-project:dev-2.x .

    it should work (not sure myself as I'm not using composer so far regularly).

  • That explains it... Thanks a lot iionly!

    I'll try the composer option for 2.x...

  • At the end, given up on Composer once more and went for the conventional installation (of copying files).

    Just for the record:

    1- I tried to uninstall the Elgg 3.0 also via Composer, but it failed saying that

    elgg/starter-project:dev-master is not required in your composer.json and has not been removed

    Package "elgg/starter-project:dev-master listed for update is not installed. Ignoring"


    Nothing to install or update

    (also complains about package phpunit/phpunit-mock-objects having been abandoned and should not be used)

    I modified the composer.jason file to add dev-master as a required one but did not work.

    Maybe my command was wrong?

    composer remove elgg/starter-project:dev-master

    2- Installing 2.x via Composer (composer create-project elgg/starter-project:dev-2.x .) failed saying:

    Could not find package elgg/starter-project with version dev-2.x

    I checked the Github. Branch 2.x exists.