Problem after putting the site online

I tested my installation for several weeks before going online, and now suddenly I have a problem with the site going to a blank page right after login.  I page is call manifest.json with a single line of text across the top.  This only happens when "restrict pages to logged in users" is activated, which I really need to work.  Any help?  Thanks....Robb

  • ok, thanks everyone for the seggestions.  Here's what I've discovered.  

    the error happens FOR ME on firefox mobile android.  I don't know if it happens on other peoples phones with firefox.  Website works correctly for the following android browsers.  Opera, chrome, duckduckgo.

    I've created a guest user at my website.  If you have an error logging in, please leave me a message.

    username: guest

    Password: elgg123456

    If you successfully get in with firefox, or an unlisted browser, please also let me know....thanks!! Robb

  • It seems is currently offline (for me at least).

    If the problem is accessing the file manifest.json with pages restricted to logged-in users, this can be fixed by making manifest.json a "public page". The "public" here has nothing to do with access level you can select for content (e.g. when making a blog posting). It means that that a whole page (in this case site.url/manifest.json) is not restricted from access by logged-out site visitors. There might be some Elgg core bug causing the manifest.json page not being accesible in some circumstances while it works in other situations (in your case not working on mobile FF while it works from desktop browsers; when testing it worked for me on one test installation but not on another with both installations on the same local server and trying to access it from the same browser).

    You could register a function for the 'public_pages', 'walled_garden' plugin hook:

    elgg_register_plugin_hook_handler('public_pages', 'walled_garden', 'make_public_manifest');

    This line of code would have to be added within an init function in start.php of a plugin, e.g. your theme plugin or you can create a new plugin where you would only add this line in the init function in start.php of this plugin.

    Then you would also add the following function in start.php (in the same plugin where you already registered the plugin hook handler function in the plugin's init function):

    function make_public_manifest($hook, $type, $pages) {
        $pages[] = 'manifest\.json';
        return $pages;

    When adding the code to an existing plugin flush the site cache in the admin section of your site. I hope the problem is then solved with this modification for you for now. I guess it might be worth to make the Elgg core developers aware of this possible problem ( so it might get fixed in a future release of Elgg.

  • thanks for the help.  The website hasn 't been offline.  Strangely there are still parts of the internet that are caching the godaddy parked location of my domain.  I had a very hard time accessing it myself until I realized to try one of the free vpn's .  That was all it took for me to be able to access it.  I'm not sure why its taking that long to update.  Thanks again.  Robb

  • hello

    what is your free vpn



  • the opera web browser comes with a free vpn.  All you have to do is go to settings and turn it on.