No CKEditor showing


I'm facing a little issue I can't solve. I know that I had this little editor (CKEditor) after I installed elgg 2.3.10 and it worked. But now it's not showing any symbols anymore, just the plain text field. I deleted CKEditor from my mods folder and uploaded it again, didnt work. I also deactivated all plugins except for CKEditor, still doesnt work.


I tried to upgrade my editor by uploading a custom CKEditor into the ckeditor folder in mod/ckeditor/vendors/ckeditor. Was that the problem? I changed everything back to the original but it wont work.


I thought maybe I have to delete the stuff in the data directory (system_cache and so on) but didnt show any effect.


The reason I wanted to change the editor is that I needed the support for uploading pictures.


edit: I guess whats showing is the editor when you click "Edit HTML". But I dont have any button to change that. I can only click on "embed" (or something like that, idk since I'm using the german translation)

  • Do you see the CKeditor plugin in the list of installed plugins in the admin area of your site? Is it enabled? If the "Edit HTML" link is missing in the top right of the textarea it might be that the CKeditor plugin is currently not enabled.

    Also check if the ckeditor folder and the files and subfolders within have the same permissions and owner:group as the other plugins in your mod folder. Maybe replacing the ckeditor folder and/or restoring it resulted in some or all files having different/wrong permissions and owner and the webserver can't access them anymore.

    When disabling or enabling or re-ordering a plugin in the plugin list the site cache gets flushed. You can also flushing the cache from the admin area when you add the "Control Panel" widget to the admin dashboard. So, no need to delete the cache files and folders in the data directory. Before changing or replacing a plugin folder in the mod directory you should always disable the plugin first via the plugin list page in the admin area. Then there shouldn't be caching issues. And when enabling the plugin again the cache gets flushed and rebuilt automatically.

    I think the only plugin that adds image upload support for the CKeditor plugin is currently the CKEditor Addons plugin ( The image/file upload functionality is rather basic but it probably works at least while the other available CKEditor plugins with image upload probably won't work anymore on Elgg 2.x.

  • Thank you, I will take a look again and try to get the CKEditor running with your advices. For now, I'm using the Tiny(idk exactly) Editor, and I was able to add image upload funcionality there, I will check the permissions and see if CKEditor will run again.