This plugin is invalid: The required file "start.php" is missing

I am maintaining a website running on Elgg 2.3.7. I have been trying to install a 3rd-party plugin called 'Widget Manager'. When I tried to activate this plugin, I got this error 'This plugin is invalid: The required file "start.php" is missing. Location: /var/www/html/mod/widget_manager/'.   The issue is that there is the start.php in this mod.

So I created an empty start.php file to fix this but it didn't solve the problem neither. The file permission for this plugin is the same as working plugins. Advice or solutions are appreciated. Thanks all!

  • Owner and group are identical to other plugins

  • No ideas. What happens to other plugins? Can you upload and activate it?

  • Other plugins with the same permission, owner and group are working fine. I can activate them - but not with Widget Manager or Widget Pack 

  • Ok, good news. Now try to delete all files with .dot at the start of filenames from widget_manager and widget_pack folders. For example:


    Then try to activate these plugins again.

  • Also, click on plugin name to check all dependencies on it (a pop-up window should open). Is there any error?

  • I deleted .gitignore and .travis.yml from both widget_manager and widget_pack. But I still have the same error.

    widget_manager and widget_pack are listed in my plugins list but they are not clickable. So there is no popup window to see their dependencies. But I can check their dependencies from manifest.xml

  • My guess is that you download the plugins from github via the "Clone and download" button and not from the RELEASES page ( and Am I right? This could explain why you have no start.php.

    Coldtrick is already working on updated versions of their plugins for Elgg 3. For example the master branch of the Widget Manager plugin already contains changes for Elgg 3 (where a start.php file will no longer be required). The development branches in a repository could be in a non-working state at any time and therefore it's risky to download the content of the repo directly via "Clone and download" (if you have a folder named widget_manager_master after unzipping it would indicate that you have done it this way). Also, a repository might not contain external dependencies a plugin requires. These dependencies would only be added when making a new release of a plugin.

    So, could you try again with the download via the links I have added above (the zip files you get should be named and If you check the content of the zips you should see the start.php files directly in the plugin folder. And when unzipping in the mod folder (or copying the unzip plugin folder into it) you should see for example mod/widget_manager/start.php on your server (and not for example mod/widget_manager/widget_manager/start.php).

  • Thank you iionly. 

    At first, I downloaded it via the 'Clone and download' button. But then RvR gave me the correct links to download widget_manager (version 8.3.2) and widget_pack (version1.3) - the same links you gave me above. When I unzipped these two zip files, these two plugins have start.php file. 

    I will try to do it again as you suggested.

  • iionly, I downloaded the widget manager and widget pack from the links you provided. Then I unzipped the files and move them to my mod/ directory, chmod directories to 755 and chmod files to 644, owner/group of widget manager's and widget pack's directories and files are exactly the same as those working plugins. But the '.... start.php is missing' error still exists.

  • I assume the error is in the system cache.
    If you gave me access to your SSH I could solve this problem.