Default homepage shows Xampp landing page

HI,

Everything looks to have installed fine with my insallatiton but when I go in to browse to my domain, it comes up with the default Xampp page that comes up when you successfully install/configure it and Apache.

I cant figure out how to get it to point to the actual elgg landing page by default for my outside users.

Any ideas?

Thanks for your help!

  • Try to activate Aarborg theme.

    Or use our just released TSN Theme https://es.wzm.me/products/view/80/tsn

  • I don't think the issue is with the Theme. I believe that elgg is not configured properly (installed inside a folder of root directory) or the index.html file of xampp is getting a priority over index.php file of elgg.

    Scenario 1: If elgg is installed inside a folder of root directory

     

    In Windows the default root directory for xampp path is C:/xampp/htdocs/. If you have installed elgg inside any folder of htdocs then you might have configured the site URL incorrectly. To correct this issue just go to Administrate > Settings > Advance Settings and change "The site URL:" to "http://localhost/elgg_folder_name" where elgg_folder_name will be your elgg folder.

    Scenario 2: If elgg is not installed in any subfolder

    If that is the case then simply delete the index.html file (within the htdocs folder there will be an index.html file that the default page for xampp. ) and hopefully this will resolve the issue. Note: delete the file with .html extension not the .php extension.

  • Thanks for the responses guys.

    Rohit I assume the """ on scenario one  url was a mistype?

    A couple things:

    1. My elgg is installed in c:/xampp/htdocs/sites/elgg

    2. some strange reason there isnt an index.html file in the main htdocs folder. just a index.php file..it then seems to skip and go to the Dashboard folder where there is one and when I edit it, its the xampp page I am seeing. so there is the  problem. I think its scanning for an index.html file possibly and since Dashboard is the first directory in alphabetical order, it may just be choosing it

     

  • For reference my settings show

    The site URL: http://localhost/sites/elgg/

    The full path of the Elgg installation: c:/xampp/htdocs/elgg/

    the full path of the data directory: c:/xampp/elggdatadirectory\

  • Rohit I assume the """ on scenario one  url was a mistype?

    Yes that was by mistake.

    The site URL: http://localhost/sites/elgg/
    The full path of the Elgg installation: c:/xampp/htdocs/elgg/

    • If your full path of the Elgg installation is c:/xampp/htdocs/elgg/ then your site URL should be http://localhost/elgg/.
    • If your full path of the Elgg installation is c:/xampp/htdocs/sites/elgg/ then your site URL should be http://localhost/sites/elgg/.

    ​You have given 2 different full path in 2 of the above comments. Configure it based on whatever is correct.

    You can also check your .htaccess and configure this:

    # If Elgg is in a subdirectory on your site, you might need to add a RewriteBase line
    # containing the path from your site root to elgg's root. e.g. If your site is
    # http://example.com/ and Elgg is in http://example.com/sites/elgg/, you might need
    #
    RewriteBase /sites/elgg/
  • HI Rohit,

    I will play with this a little esp the .htaccess thing.

    On the duplicate full paths, one is for elgg, and the other for the data directory. I read somewhere not to put the data directory under htdocs so I made a foder for it under c:/xampp/elggdatairectory. for some reason it keeps adding a "\" at the end of the url ( c:/xampp/elggdatadirectory\) regardless if i remove it and save or not

    I will provide an update and thanks for your help again!

  • On the duplicate full paths, one is for elgg, and the other for the data directory.

    No, I was not talking about the Elgg and Data Directory. I was only talking about the Elgg directory. First you mentioned that your elgg installation directory as "c:/xampp/htdocs/sites/elgg/" and then you said that your elgg installation directory as "c:/xampp/htdocs/elgg/"

  • HI Rohit..no luck last night my friend. .htaccess was set properly

    Sorry on the confusion. My settings are as follows 

    The site URL: http://localhost/sites/elgg/

    The full path of the Elgg installation: c:/xampp/htdocs/elgg/

    the full path of the data directory: c:/xampp/elggdatadirectory\

     

    Again I am not sure it even matters but it keeps adding "\" to the end of the data directory path as shown

     

    I have tried to look in all kinds of configuration to see if somehow, something is redirecting the URL or set improperly in Apache or PHP or something that keeps bringing up the page saying the below..Any othter ideas?

    Welcome to XAMPP for Windows 7.3.0

    You have successfully installed XAMPP on this system! Now you can start using Apache, MariaDB, PHP and other components. You can find more info in the FAQs section or check the HOW-TO Guides for getting started with PHP applications.

  • Update..Ok. Just looked at the error logs and seeing two errors shown below. Does this help anything?

    Logged Error 1:
    Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

    Logged Error 2:
    PHP Notice:  Undefined index: HTTP_HOST in C:\\xampp\\htdocs\\index.php on line 7
     
    In regards to Error 2, here is the output of my index.php
    <?php
     if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
      $uri = 'https://';
     } else {
      $uri = 'http://';
     }
     $uri .= $_SERVER['HTTP_HOST'];
     header('Location: '.$uri.'/dashboard/');
     exit;
    ?>
    Something is wrong with the XAMPP installation :-(
  • The site URL: http://localhost/sites/elgg/
    The full path of the Elgg installation: c:/xampp/htdocs/elgg/

    If your elgg installation path is c:/xampp/htdocs/elgg/ then your localhost path will be http://localhost/elgg/ (there will be no "sites" in your URL).