Tidypics not working

Good morning all! I had a buddy of mine test my site and when they tried to upload pics they got this message:

sorry the request is invalid or incomplete. You cannot access AJAX views directly.

How do I fix this if possible?

Thank ya,

  • Also I'm open to alternatives..just need to have an option so that my visitors can upload their images.

  • Hello,
    did you make changes to a file?
    if so you have to use notepad ++ and put in encoding UTF8 without BOM
    I had the same problem
  • Thank you so very much @jmperu! Where do I place this?


  • Mekaboo if you want to save space on your site use the imgur plugin https://elgg.org/plugins/2033439​ just register for a free account and get your key to put in the plugin and away you go

  • What jmperu was trying to say is that if you modified any source file of Elgg or a plugin (any php file, js code file or language file) and saved the file you have changed with your text editor in an encoding that includes Byte Order Mark characters (BOMs for short) you would get problems. The BOMs are characters that are not displayed in an editor but cause problems for the php interpreter and Elgg, i.e. some things will very likely not work correctly anymore. If you never modified any files within your Elgg installation but have all files in the original state or if you saved any modfied files definitely in an encoding without BOMs, there shouldn't be any issues caused by BOMs.

    Which version of Tidypics and which version of Elgg are you using? I would suggest to use the latest version of Tidypics recommended for the Elgg version you use in any case. If you use an older version of Tidypics you should still not have any issues with uploading images. But I can't fully rule out that there might be issues.

    The problem could also be caused by another 3rd party plugin that might have bugs or isn't even fully compatible with the version of Elgg you use. Do you see any errors in the server logs or in the browser console when trying to upload an image? Even if not I would suggest to test it with all other 3rd party plugins apart from Tidypics temporarily disabled to know for sure if any other plugin might cause the problem.

  • First off thank you all!

    @Herb I may look into that!!

    @iionly when I do an inspect element the issue lies with the require.js. This is making my site have issues :(

  • @Mekaboo Disable all scripts are loaded from CloudFlare CDN (and don't use these until you'll understand what you do).

    Now run 'Flush the caches' and check your browser console.

    Try TidyPics again.

  • Got it to work! I copied code from a theme that I liked but deactivated due to it messing with my SSL and placed it within an index.php file in the Aalborg theme. the issue stemmed from me still having the js from the old theme and not deleting it which I just did. I also activated CDN within my webhost. I activated the Tidypics plugin then flushed cache. Now things are working FANTASTIC!!!