Private settings not saving

hi, on my profile page i'm trying to change the privacy settings but it's not saving. I'v played about with the settings in admin (image below) but nothing works.

 

And i'v disabled some plugins i'v just added but it wasn't them ..... help to fix please :) 

 

 

so this when i change to 'private' then save goes back to 'public'

 

 

 

 

and i tested on off with this but still same :( 

 

 

 

 

thank you

  • Well, I was wrong, there is no error. I guess some plugin does it

  • none of the popups work now

    Try to flush the cache and upgrade your site. I hope you have not modified any of the core codes? 

  • ok forget the java script popup problem, cloudflare settings on speed up site was rubbish and clashed etc etc.

     

      

  • ok so popups fixed :/ my fault sorry. 

     

    But i want/need to keep this theme, i'v disabled all the last plugins one by one that i installed since the profile privacy problem.

     

    what now ?

  • i'v disabled all the last plugins one by one that i installed since the profile privacy problem.

     Now flush the cache and upgrade your site.

  • It will not help. Something is happening on the DB side. Although everything works on the newly installed Elgg.

  • i see you've helped thank you, and checked everything so i'm talking to my host atm

     

     

    thank you 

     

  • hi again 

    So i understand people in this thread have tested all the privacy settings on a test site which i really appreciate, but i just can't fix it on my side for some reason, i'v tried everything, even deleted my site off cloudflare but nothing worked.

    So i'm just going to add a note on this page profile/userme/edit explaining why so they understand.

     

    where is this page please in files please ?  profile/userme/edit

     

     

     

     

    thank you ! 

  • As I said before this issue has appeared since Elgg 2.x and it's normal because access level in metadata is deprecated.

    I can't say why this issue isn't appears in another websites with Elgg 2.x including a new installed Elgg that I've tested yesterday. I'm assume a reason is the DB caching.

    I will try to fix it and publish plugin here or GitHub because it's very important for all our production sites on Elgg 2.3.9 too.

    Additional question: is your website a new installed, or upgraded from early Elgg versions (which versions)?

  • ok thank you i understand.

     

    ok so it's just a new install from my host (auto install in my cpanel) i'v not re-installed a newer version if this is what you're meaning.  version 2.3.8

     

     profile/userme/edit  where is this page please in files ? i'll make a note in the meantime :) 

     

     

    thank you !