Trouble getting `file_tools` plugin to work

I'm running a fairly clean install (i.e., not many non-bundled plugins) of Elgg 2.3.8. I would very much like to have the features supplied by the file_tools plugin for my "groups" (which provide course/module support in a small educational institution).

Unfortunately, in spite of some effort in getting the current version (3.0) to work (installed three different ways), it just isn't working. I can upload files, but they are not displayed in the group's "all files" listing, and the "New File folder" button does nothing. (Files are listed, however, in the summary "main page" for the group.)

Has anyone else experienced these difficulties? Better yet, has anyone overcome them? I would very much like to be able to provide folder for the "Files" area in our groups. Thanks!

  • Just a wee postscript/follow-up: I've now tried installing the same plugin on another server (where I have a "test" install of Elgg) with precisely the same result. I've also done my best to follow the trail of code through plugin's github repo, but (naturally enough) can't find anything that would look problematic to me (although I'm very new to Elgg and its ways).

    I hope the plugin devs will be able to offer some support.... :/

  • If you have trouble with a plugin it's best to post directly on the plugin's page. This way chances are better that the plugin developer notices your post. As for the file_tools plugin I see that a final 3.0 release has been made on github that is not available here on the community site (not sure if Coldtrick has stopped releasing their plugins here). Maybe the final 3.0 release has no longer these issues. As it seems it can only be installed using composer though as the release of the 3.0 version of file_tools at github seems lacking the vendor dependencies.

  • Thanks, @iionly - I'm clearly still learning the ways of Elgg and its community. :)

    I have posted about this with more details in the plugin's Github issue list (linked in my original post). I have installed the final 3.0 version using Composer, and still no joy. :( 

    (It would be a shame -- IMO, of course -- if the plugin was dependent on Composer, since there are many hosting situations where Elgg will live happily, but lack access to Composer.)

    Perhaps I should put a comment on the plugin page (in the "comment bubble" link)?

  • SOLVED. It turns out I needed to flush the Elgg system cache (from the button on the main Admin panel).

    I did that, and immediately File Tools worked perfectly. I suspect that my faulty install of 3/RC3 and 3.0 without the dependencies meant that when I used composer (which appears to me to be essential) to install the dependencies, they weren't found. At any rate, clearing the cache got the plugin working.


  • What control panel are you using David? I need a control panel that allows php7.1 or 7.2 that also allows to use  nginx+php-fpm as web server. as well I prefer to use Centos 7

  • @Herb - I believe we're using PHP 7.0 in a virtual server, with Webmin as the control panel. I'm not sure that's helpful to know for this thread, though! :)

  • Thanx David I got my problem with php7.1 figured out was dovecot and I added a bit of code and it is working now so I will try elgg 2.38 upgrade to 3 soon and see how it goes and how many plugins still work afterwords