Error for Videos Plugin

I am getting the following error in my error logs for "Videos" plugin.
 
Exception at time 1520273303: TypeError: Argument 1 passed to elgg_view_entity_icon() must be an instance of ElggEntity, boolean given, called in /home/xxx/public_html/mod/videos/views/default/object/videos.php on line 23 and defined in /home/xxx/public_html/vendor/elgg/elgg/engine/lib/views.php:936 
Stack trace: 
#0 /home/xxx/public_html/mod/videos/views/default/object/videos.php(23): elgg_view_entity_icon(false, 'tiny') 
#1 /home/xxx/public_html/vendor/elgg/elgg/engine/classes/Elgg/ViewsService.php(370): include('/home/xxx/pu...') 
#2 /home/xxx/public_html/vendor/elgg/elgg/engine/classes/Elgg/ViewsService.php(306): Elgg\ViewsService->renderViewFile('object/videos', Array, 'default', true) 
#3 /home/xxx/public_html/vendor/elgg/elgg/engine/lib/views.php(337): Elgg\ViewsService->renderView('object/videos', Array, false, 'default') 
#4 /home/xxx/public_html/vendor/elgg/elgg/engine/lib/views.php(905): elgg_view('object/videos', Array, false, false) 
#5 /home/xxx/public_html/mod/videos/pages/videos/view.php(25): elgg_view_entity(Object(ElggObject), Array) 
#6 /home/xxx/public_html/mod/videos/start.php(143): include('/home/xxx/pu...') 
#7 [internal function]: videos_page_handler(Array, 'videos') 
#8 /home/xxx/public_html/vendor/elgg/elgg/engine/classes/Elgg/Router.php(100): call_user_func('videos_page_han...', Array, 'videos') 
#9 /home/xxx/public_html/vendor/elgg/elgg/engine/classes/Elgg/Application.php(436): Elgg\Router->route(Object(Elgg\Http\Request)) 
#10 /home/xxx/public_html/vendor/elgg/elgg/engine/classes/Elgg/Application.php(384): Elgg\Application->run() 
#11 /home/xxx/public_html/index.php(8): Elgg\Application::index() 
#12 {main} 
 
This shows me that there is an error in my video plugin where the owner_guid is not defined. How can I know which video is causing this error as there is no url or unique identifier to identify the cases.