Event calendar 0.81 released

This release fixes a bug that prevented the displaying of the group calendar widget and tweaks the inline calendar to make it behave more as expected.


  • I think you true ^^

    But It was very a mistake by me cause I didn't see that there is no index.php so...

  • Regarding the 1 January, 1970 issue. This is new site with version 1.5. There has never been a previous version. The 8.0 plugin was installed first. The plugin has been disabled and then re-enabled when the new 8.1 plugin was installed. I am using Firefox. Tried IE 6. Same thing. What is occurring is that the date field is cleared once the submit button is pressed and the default date appears to be 1 January, 1970. Hope this helps you find the bug. Thanks. Appreciate this plugin.

  • @Fred - I'm running the latest version of Elgg (1.6.1) and do not see this behaviour. It would be helpful if you could either test event_calendar 0.7 with Elgg 1.5, or the latest event calendar with Elgg 1.6.1 and tell me if you see the same behaviour.

    I'm not sure what you mean by "the date field is cleared once the submit button is pressed". If you select a start date, do you actually see it appear in the start date field in text format? If not, you may have a Javascript conflict with another plugin.

  • Kevin- I tried both suggestions with no change except that now I am back to December 31, 1969. Regarding the field clearing. I do actually see the date appear in the field area in text format as I click on the calendar date. I submit the event, go back in to edit and the date fields are empty. The other fields are fine. Also, the administration statistics show that I have 16 calendar events in my network now but they do not show. Let me know if you need addtional information. Thanks.

  • Fred - if you can't even get 0.7 working, I'm at a complete loss. That version has been downloaded more than 4000 times and is used by many of my clients. This thread is the first time I've heard of such a problem and I can't reproduce it with any version.

  • You might check your PHP log. It is possible that your PHP install is non standard and has some broken date functions and this might be reported in the log. It is also possible that some other plugin is interfering. You might try running 0.7 with a core Elgg 1.5 install (nothing but the core plugins) to see if that makes a difference.

    Can you give me an example of a date string that appears in your start date field *before* you click on submit (just checking to make sure that the Datepicker JS is generating a valid date string on your system).

  • Here is the date string that appears in the start date field prior to clicking on submit:

    Sat 19 Sep, 09

  • Hi Fred. Well there's your problem. The date string is mangled. The format should be something like

    Wednesday, September 23, 2009

    I tested the format you gave and it will definitely not work.

    One possibility is that you are using another plugin that uses the Datepicker and that it is loading a different setting. I suggest that you test with just the core plugins.

  • Or at least you could test with the event calendar plugin right at the bottom.

  • Hello,

    I installed 0.81 onto elgg 1.6.1.  I have a LAMP setup on Debian Lenny.  I tried to add the calendar widget onto the dashboard but I am getting

    "This widget is either broken or has been disabled by the site administrator."

    It's shows correctly in my groups.

    Any idea?