Like Button and Popular Blog Post

When someone hits the like button on a Blog it puts the blog on the landing page. Have to keep deleting the blogs or take an hour for the landing page to load. Thanks for the help. I already tried disabling plugins.

  • Forgot to add, it is only the u-tube videos that are embeded

  • My guess is that the plugin you use to allow for embedding youtube videos doesn't take into account that blog entries might also be displayed on the index page / landing page. Therefore, the necessary libraries are not loaded by this plugin on every page of your Elgg site but only on specific other pages. If an entry is to be displayed without the libraries loaded, there's a fatal error and the corresponding page doesn't get displayed correctly.

    The fix is most likely not difficult. But without knowing which plugin you use for embedding the youtube videos I can't give you a more specific advice. The fix would likely be to just load the libraries required already in the plugins init function. Then they are always loaded on all pages.

  • Thanks, using hypescraper 5.2.2 and hypeEmbed 2.1.5 HypeUi Elgg 2.3.4. It will not put the blogs on the landing page untill someone hits the like button. Blogs appear on all the other pages ok.

  • Can you check the error log on the server (Apache and/or PHP error logs) to see if there's a entry made at the time the landing page fails to load? An error log entry could help to narrow down the cause.

  • The landing page always loads, it just takes longer each time a blog is added to landing page when someone hits the like button. There is only one error in php:

    [09-Nov-2017 17:17:26 America/Chicago] PHP WARNING: 2017-11-09 17:17:26 (CST): "Invalid argument supplied for foreach()" in file C:\inetpub\wwwroot\xxx\mod\hypeUI\views\default\navigation\menu\filter.php (line 3)


  • here is the file:


    foreach ($vars['menu']['default'] as $item) {
            echo elgg_view('navigation/menu/filter/item', [
                    'item' => $item,
                    'link_class' => 'nav-item is-tab',


  • I did try and reproduce that error. I get the error when I enable hypeinteractions. When hitting the comment button the box comes up, but no place to type anything. So I guess I am calling a function and no place to put the input. Thanks


  • I have tried a few things to see if I could reproduce the error. It happens when I hit the link Make a Blog post.



    [10-Nov-2017 00:31:40 America/Chicago] PHP WARNING: 2017-11-10 00:31:40 (CST): "Invalid argument supplied for foreach()" in file C:\inetpub\wwwroot\xxx\mod\hypeUI\views\default\navigation\menu\filter.php (line 3)

  • The "error" you posted is not exactly an error but just a warning that foreach() loops over an array with 0 items (no results found to work with). It's a bit annoying to get these warnings (could be avoided to happen if checking in the code if execution of the foreach() loop is necessary at all).

    I think the real cause is somewhere else to be found in the code of the hypeInteractions plugin. But I can't really help you here because all the hype* plugins are rather complex and often depending on other hype* plugins to be installed (even if not reporting this dependency in some cases unfortunately).

    My advice would be to check if any newer releases of the hype* plugins are available. As Ismayil doesn't necessary publishes all new releases of his plugins here on the community site you would better check at his github account ( You could also follow the "Code repository" link on the plugin pages here on the community site to get to the corresponding plugin repo at github. Try it the latest zip release available on the releases tab. Don't use the "Clone or download" button because you don't get the vendor dependencies included in the zip this way. Try it with the latest available releases of all hype* plugins you use. If you are lucky, the problem is fixed then. If not, you might best open an issue at github in the corresponding plugin repo reporting the issue (try to narrow down the problem as best as you can at least to the one plugin causing the issue).

  • Thanks iilony, disabled hypeinteractions and still have error I will look in other areas

    Thank Bo