Trouble installing elgg 2.3.2 on a Linux VPS server

Hi everyone. I am having trouble installing elgg 2.3.2 on a linux VPS. The last time I installed Elgg was on a shared hosting plan and I had no issues then, but I am completely new to VPS hosting. The reason I switched to a VPS host was because of poor performance of my Elgg site on a shared hosting package. 

Some features of my VPS package are as follows:

1 IP Address, 2GB RAM, 50GB Storage, 1vCPU, 1TB Bandwidth

My can be found at (

Steps followed:

1. I uploaded the elgg 2.3.2 zip file on Cpanel and extracted the files to the public_html folder.

2. I created the data folder in the main directory (/home/rnetw)

3. I created a database and assigned a user with full privileges

4. I tried going to for the install page, but only got a blank page on the install page

Any form of help would be appreciated. I am trying to setup a network site for employee communication at my company. 




  • I see there's already a fully working (non-Elgg) site at this domain...

    If your posting is no spam: have you extracted the Elgg zip into a subdirectory of public_html? Then you would have to go your "yourdomain.url/subfolder_name" in the browser for the installation. If the page is blank, it might be that whatever you have installed in public_html directly might have a .htaccess blocking access in subfolders.

  • Thanks for the reply @iionly. No I am no spam. I put up a temporary index page I'm planning to incorporate into my elgg installation as a plugin. I extracted the Elgg zip in the public_html directory itself so that I excess the site without the /subfolder_name at the end, but I will try to do it as you described to check if there is indeed a .htaccess thats blocking access. 

  • Okay so I tried to extract the Elgg zip in the public_html/rail directory and moved the data folder to the public_html/ directory but I actually get the same issue ( ) still comes up as a blank page. The only .htaccess in the public_html/rail directory, is the one that comes with the Elgg zip. Could this be an issue with the settings on the myphp.php file?

  • First: do NOT create the data directory inside public_html (or in other words the so called document root folder which happens to be public_html in your case). The data directory should not be directly accessible over the Internet and the easiest way to achieve this is to create it outside the document root folder. Beside this rule the location of the data directory doesn't really matter as you provide the path to this folder during the installation (regardless where it is). So, the data directory in your home directory is perfectly alright!

    I just made some testing with installing Elgg 2.3.4 and I got a white screen when trying to install Elgg if I had created the settings.php file myself in the elgg-config folder prior starting the installation. This is a bug in Elgg I just opened an issue about. So, if you also have created settings.php in the elgg-config folder (or if there is a file with this name in this folder), just delete it. It will get created by Elgg during the installation (you only need to set the permissions for the elgg-config folder to 777 for the installation - restoring the original 755 permissions afterwards).

    If the settings.php file is not the cause in your case, you would need to look into the Apache and/or PHP error log to see if there's some entry that might explain why you only get a white screen.

    If the problem would occur at a later time during the installation the reason could be that the pdo-php extension might not be installed on the server (that's necessary in any case for Elgg connection to the database). But I would say it less likely that the installation wouldn't even start if it's missing.

    I really can't say if the presence of this index page might be a problem preventing the installation of Elgg, because I don't know what files (first of all a .htaccess file) might exist in your public_html folder. If you do have a hidden .htaccess file already in public_html before copying Elgg to the server, remove it (as Elgg will come with it's own .htaccess containing necessary stuff).

    On thing comes to my mind right now though... open the .htaccess file (of Elgg) installed on your server and check if the following lines are present

    <FilesMatch "(nginx|htaccess).dist">
        order allow,deny
        deny from all

    If this is the case, just delete them (they are absolutely not necessary anymore with recent versions of Elgg and might prevent Elgg to work on Apache 2.4 if the mod_compat module of Apache is not installed). If you have these lines removed, try the installation again.

  • @iionly I'd like to thank you again for your assistance, I really appreciate it a lot. I am still trying to pinpoint the issue with my installation. Below are the observations I have made so far based on your advice:

    1. There is no settings.php file in the elgg-config folder

    2. There is no .htaccess file in the public_html folder

    3. I tried removing the lines of code you mentioned in the .htaccess file but this didn't help

    4. I tried installing version 1.8.5 and the installation page showed up and the installation proceeded with a notice under PHP which said "It is recommended that the PHP extension mbstring be installed". The test of the rewrite rules was successful. The rest of the installation proceeded smoothly and Elgg 1.8.5 was installed successfully. 

    I hope that based on what I've mentioned above and your expertise with Elgg, you can be able to assist me successfully install Elgg 2.3.2

    My server-side knowledge is very limited. I wanted to ask, how do I enable Apache and PHP error reporting, as I could not find the php.ini file on my Cpanel file manager.

    Thanks again for assisting me with this issue

  • I think I've solved the issue. The PHP extension, mbstring was not enabled on my server. As soon as I enabled it, the installation proceeded smoothly. Thanks to your assistance I was able to get a solution quickly.