Version 2.3

What's the difference between 2.3 and 1.8? What is better ?

thank you

  • Elgg 2.3 is the latest stable release. Elgg 1.8 is no longer supported.

    If you still wish to use an Elgg 1.x version please upgrade to 1.12 as that is still supported.

    But please consider upgrading to Elgg 2.3 as that will be the version most plugin developers work on an therefor you can get more features.

  • I'm missing the backward compatibility thing that we all have seen everywhere for the last decade. Why would new code not be able to take previous plugins and add the new portability on the fly? When you load a plugin I myself can see where the system could create the missing attributes and files and then give you a print out of what was added so that you could modify the plugin code accordingly.

    I might be crazy but the idea seems so simple and doable. A lot of plugin developers have abandoned previously working plugins because they assume at some point they will be fly ported.

    I'm not sure fly ported is something that many people understand. I'm 51 and everything I design new always takes old plugins and adds the missing files and attributes, even calls the new function in place of the old etc. Plugins should have an auto port config file writeable by the system. This would be a reference point for updating a plugin that is outdated.

     

  • The backward compatibility of Elgg doesn't get broken just for fun. There's always a reason: improving performance, support for modern web technologies, better consistency in code for easier development, making use of web-standards formerly not existing, etc. etc....

    With a compatibilty layer you would contradict any efforts in getting better performance. And it would likely still not work in all cases with any old plugins because a plugin released years ago just couldn't foresee all future developments in web technologies. And a plugin developer might have coded some things just a tiny bit different in some cases that still worked but would require special treatment in a compatibility layer with many exceptions for specific plugins. Just a lot of work would be necessary to maintain such a compatibility layer - much more work than just update a plugin code to work on newer versions of Elgg.

    Elgg keeps backward compatibility in major version since Elgg 1.10 with sematic versioning (http://semver.org/). Before 1.10 it was a bit messy - granted. But it had to be introduced at some point. Unfortunately, the big break in backward compatibility from 1.8 to 1.9 is not yet in consistency with semver (so 1.8 to 1.9 is kind of a major release jump). But plugins written for 1.10 (even most plugins for 1.9) still work up to 1.12. And the changes necessary for 2.x are not that severe either (mostly theming stuff) - much less than the changes between 1.8 to 1.9. And again, all plugins written for 2.0 - 2.2 should still work on 2.3. Only 3.0 will again break backward compatibility as it's a new major release - but again it will not break backward compatibility without reason.

    Are there really that many old plugins where an updated version is necessary? In some cases other developers forked the abandoned plugins to make new releases for newer Elgg versions. Or there are alternative plugins available that provide the same functionality.

Beginning Developers

Beginning Developers

This space is for newcomers, who wish to build a new plugin or to customize an existing one to their liking