if I want to add another blog, I get a error message: "Excuse me. The requested page could not be found"

instead of "add blog" button  there is only ":add"

the same problem I have with everything!
to add groups or add  message - everywhere only the button ":add" and the error message:
Excuse me. The requested page could not be found.

can someone help me???

excuse my english - I use the google translated ...
i use the german elgg - the error message is:
Entschuldigung. Die gewünschte Seite konnte nicht gefunden werden.


  • Choose an 'English' language. Still problem now?

  • I don't think it's a language file issue. The raw text shown ":add" seems like an incomplete language string (a complete string would be for example "blog:add"). As the language string is incomplete the raw string is displayed instead of the intended text that's in the language file because there's no match. Elgg would complete the language string for the add button depending on the page context internally under normal conditions. So, something is broken on your Elgg installation.

    Could it be that you have some faulty 3rd party plugin / theme installed? Maybe a plugin not compatible with the Elgg version you use? You should try temporarily disabling all 3rd party plugins for testing. If the button text for example for blogs, pages, files etc. shows correctly then, the issue is with one of your 3rd party plugins and you can enable them again one by one to figure out which one.

    If the issue is still there with all 3rd pary plugins disabled, the Elgg installation itself might be damaged. For example, some files could be missing or be incomplete. In this case I would suggest to copy the same version of Elgg over your install folder. This should add any missing files and would also replace any existing files that might be damaged for whatever reason.

    If it still doesn't work, the question is if upgrading to the latest version of Elgg might help (if you are not using it already). On the other hand, if you upgraded your site from an older version of Elgg in the past (at least a minor version upgrade like 2.2 to 2.3 or even a major version upgrade like 1.12 to 2.x) and you haven't cleaned up the install folder from old files no longer present in the new version it might also cause some issue (can't tell if this would be the reason for the button text issue).

  • I'm working with Andreas on the same problem.
    Thanks a lot for your answers!

    We switched back to English language but there's still the same problem.

    The problem occured after having updated Mautic which also runs on the same server using the same database.

    It seems that the other application has changed something so that Elgg doesn't work properly anymore.

    However, Mautic doesn't work at all, after the update. Well, it seems we've ignored the "never touch a running system" rule... ;)
    We hoped to be able to repair Mautic so that maybe Elgg would work again but we have not managed this, until now and always get this error message: "ERR_TOO_MANY_REDIRECTS" when starting Mautic. We do not know why we get this error message and if it effects Elgg, too.

    However, Elgg is used by a lot of users and we do not dare to change anything.
    At the moment we try to do a new elgg installation of the same version (2.0.1) on a free web server and import our database so that it might run there and afterwards we will "play around" on our server with the damaged one and inform you, if it works again!



  • I can't help you with Mautic. Never had heard of it.

    Do you really use only one database both for Mautic and Elgg? Maybe the upgrading of Mautic has broken this database then (as Mautic might not be able to handle the Elgg specific stuff in the database and instead of ignoring it it changed that, too, and maybe couldn't finish the database upgrade correctly then).

    Or is it the install folder that's the same only? Maybe Mautic also comes with an .htaccess file? And maybe the .htaccess files collide?