is memcached any faster

Hello, I am wondering if anyone is still using memcached with elgg 2.3.3. It is easy to set up and already in the settings.php so I am wondering if any of you are using it and if so how is it or is it redundant with the simple cache/symlink thing already in the core (although I think simple cache just does static files not mysql instructions, but my newbie ignorance is why I am asking?). As well what about Redis? Any thoughts?

  • yes I tried localhost, domain name,, and server ip. neither works

    as well I have tried

    // namespace prefix
    $CONFIG->memcache_namespace_prefix = 'ablight';

    and it doesn't do it either

  • did you start the memcached service?

  • yes of course..memcached is running ..I had a problem getting goaccess stats to work and it was owner of the directory/files that was the trouble. I was running a cron as root and it wouldn't allow it because the dir was owned by admin so I am wondering if memcached can't access elgg dbase because elgg is owned by admin but I don't know how and can't find any info on if this could be the problem and if so how to get memcached to allow user admin

  • Also note the Boot Cache will use memcache automatically if enabled. In 3.0 there's an opportunity to cache a lot more metadata if someone puts in a little work.

  • I set boot to work and hope it does and changed my setting memcached input to 

    $CONFIG->memcache = true;

    $CONFIG->memcache_servers = array (
        array('localhost', 11211),
        array('', 11211),

    I also set memcached OPTIONS="" and now it is working. I hope this helps someone in the future.

  • If you only have one memcache server, just include one in the array.

  • I only have one memcached server and I tried it with just one in the array and it wouldn't work no matter what I used as input but with both and localhost it works. I am not sure why it takes two for me instead of one but I am a happy man and I hope someone else may find this useful if a singular array doesn't work. 

  • I have to say for the record, my elgg is showing two memcached servers in stats overview ..a localhost and a but I only installed memcache with the usual yum script and as I said it wouldn't let me only use a single array entry so I don't know what to say. When I open the PHPMemcachedAdmin I set up it shows 4 servers but the second one is not responding. (see below)

    Cluster Default Servers List
    Version 1.4.36, Uptime : 0 day 2 hrs 25 mins
    Server did not respond
    Version 1.4.36, Uptime : 0 day 2 hrs 25 mins
    Version 1.4.36, Uptime : 0 day 2 hrs 25 mins

Performance and Scalability

Performance and Scalability

If you've got a need for speed, this group is for you.