change password is failing in elgg 2.1.3

anyone know why this is occurring and how to solve it?
 

  1. change password for existing account
  2. system logs user in
  3. log out
  4. log in again
  5. system rejects new password and user cannot login

this is occurring for me and other users.

  • I've just tried in Elgg v2.3.1 by scenario:

    1. Change current password and type a new password
    2. Get error message: "Failed current password check." and success message "Password changed" both
    3. Log out
    4. Log in again witn new password
  • i am using an older version of elgg to you, but it looks like there may be different issues with both versions

  • Disabled my custom theme and tried again--all works like a charm... w/o any issues and error messages...

    Try to compare 2 cores

    Maybe this?

  • i have disabled my theme and also changed the file you provided, but that didn't fix it for me. i found this in the log:
    2017/03/13 10:17:34 [error] 23164#0: *45226 FastCGI sent in stderr: "PHP message: WARNING: Deprecated in 1.9: The 'login' event was deprecated. Register for 'login:before' or 'login:after' Called from [#13] /var/www/html/mysite/vendor/elgg/elgg/engine/classes/Elgg/EventsService.php:69<br /> -> [#12] /var/www/html/mysite/vendor/elgg/elgg/engine/classes/Elgg/EventsService.php:166<br /> -> [#11] /var/www/html/mysite/vendor/elgg/elgg/engine/lib/elgglib.php:660" while reading response header from upstream, client: xx.xx.xx.xx, server: mysite.org, request: "POST /action/login HTTP/2.0", host: "mysite.org", referrer: "https://mysite.org/&quot;

  • anyone got any thoughts on this?

  • this was fixed when i upgraded my live site to 2.3, but now the problem is back again - but only on my live site!

  • ah, this was apparently caused by the elgg plugin for fail_2_ban.

  • this is strange. i spoke too soon. after i removed elgg from fail 2 ban's settings i was able to login correctly after resetting the password. however, now i am again unable to reset the password and login correctly. even if i disable fail 2 ban completely, i still cannot reset the password in elgg successfully. :/

  • i have now fixed this (i think) by upgrading some of the views i had over-ridden in my theme (fingers crossed).