Trouble on Ubuntu 16.04 with PHP 7.0

Using Ubuntu 16.04 and PHP 7.0 with webserver located at /home/me/Sites.

Got this message: 

exception:title

An unrecoverable error has occurred and has been logged

with no error message in /var/log/apache2/error.log. At first, had downloaded the elgg archive and expanded to my webserver directory. PHP, Apache, and MySQL all work, based on another installation (WordPress). Then deleted all elgg files and used composer. Found that php-gd, php-xml, and jquery-imgareaselect were missing and prevented installation. After adding these three, still got this exception. Changed the .htaccess file so that Apache would direct to the sub-directory of my localhost. Still not working. There is no settings.php file, nor a settings.example.php file. Tried composer install again, which showed no errors.

Appreciate any suggestions! Thanks.

  • Figured it out.

    /etc/php/7.0/fpm/php.ini defaults with no error log. Uncommenting the error_log line and adding a path (made mine /var/log/apache2/) got it to work.

     

  • Found the settings.example.php file in vendor/elgg/elgg/elgg-config/. It's not in the top-level elgg-config directory.

  • This exception error still appears while setting up the site. But no error messages are being logged.

  • Got past the setup wizard. Had to make sure the MySQL user existed with the correct password and the database settings were correct. Otherwise, the exception error came up.

  • Which Elgg version are you trying to install? Make sure you have sufficient permissions when running composer - you should be using composer create-project (see installation docs).

  • I'm using 2.3.1. My installation was successful after some tweaks to system files. Had nothing to do with compose. composer create-project did not work without other missing modules. Also what didn't work was composer self-update. In the end, I needed php-gd again (no idea what happened to it), php-xml, and jquery-imgareaselect. After that, I still had problems. Found that editing php.ini from Ubuntu 16 required uncommenting the error_log line.

    Then I had to make sure the settings were perfect or I still got the exception message with no log results.

Beginning Developers

Beginning Developers

This space is for newcomers, who wish to build a new plugin or to customize an existing one to their liking