Help please re subgroups - au_subgroups plugin

I have the latest Elgg version, and latest versions of groups, group_tools and au-subgroups 2.1.0.

Most of the plugin functionality works well.

However when I try to transfer a group to be a sub-group of another existing group, I get the following error.

I have looked at the posts, I have tried and tested many things for hours, including trying to add php to au_subgroups, but no luck, hence my cry for assistance.

Maybe I am operating it incorrectly? I am the owner of the target and base groups, i go to edit group for the base group, then choose my target group to own from Make this group a subgroup of another group by searching and selecting the target group, then pressing save. I then get the error.

To add a possibly related problem, when i click on Related Groups I get the following error:

Page not found

Sorry. We could not find the page that you requested.



  • As I already posted in the AU Subgroups plugins seems missing some code. I would suggest to report the issue to Matt either at or If this functionality ever worked, Matt would be the one who could fix it the easiest as the code would hopefully still be available for him even if it's missing in the released plugin. It would be much more difficult to fix it for anyone else because we would first have to figure out what exactly is supposed to be done by the missing code and then come up with the necessary code.

  • Hi everyone,

    I have discovered my own answer!

    In fact the au_subgroups plugin has been updated by Matt to a new version which when downloaded  from githubworks just fine.

    Thanks Matt and Iionly

  • Kia ora Phil

    I'm experiencing exactly the same issue - and although I've taken your suggestion (the latest release from github), it's still not working - either to delete or transfer a subgroup. I'd be seriously grateful if you were able to give any further pointers on this one (or anyone else!)

    With grateful thanks....

  • Kia ora Jamie,

    Didn't expect there is someone else using elgg in New Zealand.

    If you has access to your server, you might consider using composer to install the plugin:

    For me, after installed the plugin using composer, transfer a subgroup is working, but deleting a subgroup and listing all subgroups are not working. The fix is to edit the start.php file: inside the function au_subgroups_pagehandler you need to add two lines of code - add `return true;` below `echo elgg_view('resources/au_subgroups/list');` and `echo elgg_view('resources/au_subgroups/delete');`

    like below:

    function au_subgroups_pagehandler($page) {
      // dirty check to avoid duplicate page handlers
      // since this should only be called from the route, groups hook
      if (strpos(current_page_url(), elgg_get_site_url() . 'au_subgroups') === 0) {
        return false;
      switch ($page[0]) {
        case 'add':
          set_input('au_subgroup', true);
          set_input('au_subgroup_parent_guid', $page[1]);
          echo elgg_view('resources/au_subgroups/add');
          return true;
        case 'list':
          echo elgg_view('resources/au_subgroups/list');
    return true;
        case 'delete':
          echo elgg_view('resources/au_subgroups/delete');
    return true;
        case 'openclosed':
          set_input('filter', $page[1]);
          echo elgg_view('resources/au_subgroups/openclosed');
          return true;
      return false;



  • Kia ora Phil

    Right back atcha! Nice to know you're here (somewhere!). I'm so grateful for this fix - could hardly believe the group obediently disappeared after prolonged failed attempts. Thanks very very much indeed.


  • Gidday you blokes. Another kiwi - just playing about with Elgg. Be interested to know what you guys are doing with Elgg in NZ :-)

    I would like to get sub groups going for a demo - what versions of Elgg are you run AU Subgroups on? I have 2.3.4. Will it work on that?

    Alternatively, is there any other options for sub groups? I haven't found any in my searches.



  • Kia ora Don

    Hey! Great that you're using elgg in NZ. We're using it extensively in our NGO in Taranaki. It's brilliant. AU Subgroups is the puppy for what you're after, and works more or less perfectly (aside from the hiccups detailed above). What are you using elgg for?
    Nga mihi nui, Jamie

  • Kia Ora. I have been playing with Elgg since it was v0.9 - just because it is interesting. Our local community network showed some interest but wound up just going back to Joomla. 

    I have been interested in doing something with it for ages - but has yet to pan out. EG - mentioned it to my son's cricket club, but they thought Criqhq could do it all ... well, how'd that work out? (

    Also my other son's playcentre was interested  - but the national playcentre association hired some big wig developers to provide a 'solution' .... which we have yet to see.

    Anyway - I deleted my old install when tidying up the server and now putting it on again - see if I can interest the playcentre again. 

    Basic problem is that I like playing with the software a lot more than I like trying to sell the idea to people :-)

    ANyway - when I get it going, how about I set up a group for NZ elgg admins :-)


  • Kia ora dear Don

    Interesting! We use it extensively and find it invaluable for our team. I'm interested in the group idea for discussion. Whereabouts are you based?
    Cheers, Jamie