ajax error

hello . i cant be able to upload pictures on my elgg platform it brings the ajax error. and advise please

  • Had you asked the same question before? Sorry, if it wasn't you but the same question was asked recently and as far as I remember there was no response at all on the answer I had given.

    What I can say to this issue:

    • Which version of Elgg?
    • Are you trying to upload images with the Files plugin, with Tidypics or something different?
    • In case of Tidypics, are you using the latest available, recommended version of the plugin for the version of Elgg you use?
    • Could it be that you are using other 3rd party plugin not recommended for the version of Elgg you use, e.g. not explicitly recommended for any Elgg 2.x version? Have you tried if the error still occurs with all other 3rd party plugins disabled except Tidypics (if you use Tidypics for the image upload at all)?
    • If using Tidypics have you tried the basic uploader instead of the html5 uploader to see if the error is caused by the html5 uploader (resulting in an ajax error) or the problem might be caused by something different?
    • Have you looked into the server error log if there might be some errors logged explaining the cause of the issue?