simplecache not loading javascript files


I've installed a new copy of elgg 1.5rc1 on GoDaddy:

  1. copied tar.gz file
  2. created a new db
  3. made it all working with default settings

For some reason all javascript functionality is not working. On my local xamp installation everything works, so I guess it has something to do with the godaddy environment.

When viewing the source I noticed that the links in the header are cached using the new simplecache. In addition new loaded profile images are shown as broken images as well (also going through the caching mechanism),

Any help will be appreciated,


  • There is a site admin option to turn off simplecache.

    Try that and see what happens.

  • I tried that as well - doesn't help. Also, when the feature is disabled the html is still created with cache infomation.

    For example:

    <script type="text/javascript" 

  • @Guy


    Thank you !! I have same problem on GoDaddy, but I have other Host (HostMoster) where there's no problems w/ RC1, RC2 at all, only GoDaddy just doesn't want to Go !


  • @Dhurp,

    You're right, I didn't find this problem on other severs. I suspect it is related to the new simplecache module, but I'm not sure.

  • Can you confirm that the problem persists with RC2? A change was made to the simplecache mechanism after RC1 was released.

  • Yes, it's still in rc2 - I can give you access to a live system if you need to

  • Can't be too sure -- because only GoDaddy gives problem.. I've installed for testing whew 4 or 5 times all of last night  thinking I must have had some corrupt or incomplete files;;; still stuck with no js functionality ;-( My head's bursting w/ headache -- I don't want to try to debug to see if G/D is actually causing the problem. I'm lucky b/c I have other server for me, but my friend's running G/D ! Maybe I'll tell him to switch ;;O

  • Very curious.

    1. If you turn simplecache off now, does it work? (In RC1 it was jammed to on for CSS and JS; this is no longer true.)
    2. If 1. does work, could you check that the simplecache directory has been created in your data directory?
    3. If 1. does NOT work, could you check for any PHP error messages (either on-screen or in a log) if you load the file directly?


  • Ben,

    I have installed with the default settings so initially simple cache is turned on and is actually exists within the data directory.

    Something else, which may assist, resources that are loaded into the data directory, for example, profile icon, do physically exist within the data directory however, are not displayed on the web (broken link images)

    Turning off the simple cache doesn't help. (I do see an improvement in rc2 where css is not affected anymore when simplecache is turned off).

    So, i guess this analysis brings us to believe it has something to do with the data directory? Anyway, i tried it both within the installation directory and outside the installation directory, and am getting the same results.